summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-12-19 17:59:43 +0000
committerTom William Payne <twp@gentoo.org>2004-12-19 17:59:43 +0000
commit0bed6ad0367174b81520535cc90bf6fc0c7ec54d (patch)
tree34ddbc0c3f17c6d95cc0223d42c2a1b1940be94a
parentfix bluefish-0.13 (bug #74174) (Manifest recommit) (diff)
downloadgentoo-2-0bed6ad0367174b81520535cc90bf6fc0c7ec54d.tar.gz
gentoo-2-0bed6ad0367174b81520535cc90bf6fc0c7ec54d.tar.bz2
gentoo-2-0bed6ad0367174b81520535cc90bf6fc0c7ec54d.zip
Prevent sandbox violation. Bug # 73672. Version bump. Bug # 74203.
-rw-r--r--x11-wm/ion3/ChangeLog8
-rw-r--r--x11-wm/ion3/Manifest6
-rw-r--r--x11-wm/ion3/files/digest-ion3-200411041
-rw-r--r--x11-wm/ion3/ion3-20040906.ebuild6
-rw-r--r--x11-wm/ion3/ion3-20041005.ebuild6
-rw-r--r--x11-wm/ion3/ion3-20041104.ebuild69
6 files changed, 91 insertions, 5 deletions
diff --git a/x11-wm/ion3/ChangeLog b/x11-wm/ion3/ChangeLog
index 4f69ed44c2d0..ce747cb93497 100644
--- a/x11-wm/ion3/ChangeLog
+++ b/x11-wm/ion3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/ion3
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.8 2004/10/05 08:47:14 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.9 2004/12/19 17:59:43 twp Exp $
+
+*ion3-20041104 (19 Dec 2004)
+
+ 19 Dec 2004; Tom Payne <twp@gentoo.org> ion3-20040906.ebuild,
+ ion3-20041005.ebuild, +ion3-20041104.ebuild:
+ Prevent sandbox violation. Bug # 73672. Version bump. Bug # 74203.
*ion3-20041005 (05 Oct 2004)
diff --git a/x11-wm/ion3/Manifest b/x11-wm/ion3/Manifest
index 1af38723d05b..e9986b666d9d 100644
--- a/x11-wm/ion3/Manifest
+++ b/x11-wm/ion3/Manifest
@@ -1,5 +1,6 @@
-MD5 6cebf1203ea19cf2422ad193738ec313 ion3-20041005.ebuild 1481
-MD5 c5a457654cef1fd61d9ec2258b00fb20 ion3-20040906.ebuild 1657
+MD5 a75cb4d91491819a6b6ac8ac211b3e3d ion3-20041005.ebuild 1603
+MD5 e5680a683a5b642d4a9ed6fdf253df09 ion3-20040906.ebuild 1779
+MD5 a75cb4d91491819a6b6ac8ac211b3e3d ion3-20041104.ebuild 1603
MD5 f6060f544ccc1dc679eac038d92ffa64 ChangeLog 1161
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
MD5 e5e408ab1f83116c2138a26b20c86653 files/pwm3.desktop 170
@@ -7,5 +8,6 @@ MD5 09b215ad9f8569d0285311935897785a files/ion3-20040316_p1-rename.patch 2248
MD5 5e2a511f6530e0cee20b7e6dfbebc3e7 files/ion3-20040316-libtu-I.patch 357
MD5 0e1e0675cbe6c598285db1ba294fa634 files/digest-ion3-20040906 68
MD5 77c936250963ebe695b1d532a1f2c679 files/digest-ion3-20041005 68
+MD5 570ce937c79c725002d3109eb0c274d3 files/digest-ion3-20041104 68
MD5 00450ed1292b72e2be71b9860c4db6ee files/ion3.desktop 217
MD5 aac436d9230b2b3cda72feb184295c1a files/ion.desktop 214
diff --git a/x11-wm/ion3/files/digest-ion3-20041104 b/x11-wm/ion3/files/digest-ion3-20041104
new file mode 100644
index 000000000000..671a2299d76c
--- /dev/null
+++ b/x11-wm/ion3/files/digest-ion3-20041104
@@ -0,0 +1 @@
+MD5 e187a0ca83642afddf3b21898b683ced ion-3ds-20041104.tar.gz 539840
diff --git a/x11-wm/ion3/ion3-20040906.ebuild b/x11-wm/ion3/ion3-20040906.ebuild
index 2ab34cdec3e0..49ddc40adaf4 100644
--- a/x11-wm/ion3/ion3-20040906.ebuild
+++ b/x11-wm/ion3/ion3-20040906.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20040906.ebuild,v 1.1 2004/09/06 18:55:40 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20040906.ebuild,v 1.2 2004/12/19 17:59:43 twp Exp $
inherit eutils
@@ -51,6 +51,10 @@ src_install() {
MANDIR=${D}/usr/share/man \
DOCDIR=${D}/usr/share/doc/${PF} \
LOCALEDIR=${D}/usr/share/locale \
+ LIBDIR=${D}/usr/lib \
+ MODULEDIR=${D}/usr/lib/ion3/mod \
+ LCDIR=${D}/usr/lib/ion3/lc \
+ VARDIR=${D}/var/cache/ion3 \
install || die
prepalldocs
diff --git a/x11-wm/ion3/ion3-20041005.ebuild b/x11-wm/ion3/ion3-20041005.ebuild
index 841af9b86ca4..ada36bad6d2f 100644
--- a/x11-wm/ion3/ion3-20041005.ebuild
+++ b/x11-wm/ion3/ion3-20041005.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20041005.ebuild,v 1.1 2004/10/05 08:47:14 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20041005.ebuild,v 1.2 2004/12/19 17:59:43 twp Exp $
inherit eutils
@@ -50,6 +50,10 @@ src_install() {
MANDIR=${D}/usr/share/man \
DOCDIR=${D}/usr/share/doc/${PF} \
LOCALEDIR=${D}/usr/share/locale \
+ LIBDIR=${D}/usr/lib \
+ MODULEDIR=${D}/usr/lib/ion3/mod \
+ LCDIR=${D}/usr/lib/ion3/lc \
+ VARDIR=${D}/var/cache/ion3 \
install || die
prepalldocs
diff --git a/x11-wm/ion3/ion3-20041104.ebuild b/x11-wm/ion3/ion3-20041104.ebuild
new file mode 100644
index 000000000000..e7331b541f3c
--- /dev/null
+++ b/x11-wm/ion3/ion3-20041104.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20041104.ebuild,v 1.1 2004/12/19 17:59:43 twp Exp $
+
+inherit eutils
+
+MY_PV=${PV/_p/-}
+MY_PN=ion-3ds-${MY_PV}
+DESCRIPTION="A tiling tabbed window manager designed with keyboard users in mind"
+HOMEPAGE="http://www.iki.fi/tuomov/ion/"
+SRC_URI="http://modeemi.cs.tut.fi/~tuomov/ion/dl/${MY_PN}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86 ~amd64 ~hppa"
+IUSE="xinerama"
+DEPEND="virtual/x11
+ app-misc/run-mailcap
+ >=dev-lang/lua-5.0.2
+ !x11-wm/ion3-svn"
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+
+ autoreconf
+
+ local myconf=""
+
+ if has_version '>=x11-base/xfree-4.3.0'; then
+ myconf="${myconf} --disable-xfree86-textprop-bug-workaround"
+ fi
+
+ use hppa && myconf="${myconf} --disable-shared"
+
+ econf \
+ --sysconfdir=/etc/X11 \
+ `use_enable xinerama` \
+ ${myconf} || die
+
+ emake \
+ DOCDIR=/usr/share/doc/${PF} || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ ETCDIR=${D}/etc/X11/ion3 \
+ SHAREDIR=${D}/usr/share/ion3 \
+ MANDIR=${D}/usr/share/man \
+ DOCDIR=${D}/usr/share/doc/${PF} \
+ LOCALEDIR=${D}/usr/share/locale \
+ LIBDIR=${D}/usr/lib \
+ MODULEDIR=${D}/usr/lib/ion3/mod \
+ LCDIR=${D}/usr/lib/ion3/lc \
+ VARDIR=${D}/var/cache/ion3 \
+ install || die
+
+ prepalldocs
+
+ echo -e "#!/bin/sh\n/usr/bin/ion3" > ${T}/ion3
+ echo -e "#!/bin/sh\n/usr/bin/pwm3" > ${T}/pwm3
+ exeinto /etc/X11/Sessions
+ doexe ${T}/ion3 ${T}/pwm3
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/ion3.desktop ${FILESDIR}/pwm3.desktop
+
+}