summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-05-22 16:11:26 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-05-22 16:11:26 +0000
commit09a2c6ba9f7d8e8540655d1f980f1c503399c5ac (patch)
treec327248fd20892d01a5c0c2ae5950e33754c8a7b
parentChanged cvs server location, closing bug #50438. Added to ~ppc (Manifest reco... (diff)
downloadgentoo-2-09a2c6ba9f7d8e8540655d1f980f1c503399c5ac.tar.gz
gentoo-2-09a2c6ba9f7d8e8540655d1f980f1c503399c5ac.tar.bz2
gentoo-2-09a2c6ba9f7d8e8540655d1f980f1c503399c5ac.zip
Fix os.utime() on hppa. utimes it not supported but unfortunately reported as working.
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.3.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.3.3.ebuild4
-rw-r--r--dev-lang/python/python-2.3.4_rc1.ebuild4
4 files changed, 15 insertions, 4 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index b150569da558..96ae65d07cbc 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.93 2004/05/15 21:05:17 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.94 2004/05/22 16:11:26 gmsoft Exp $
+
+ 22 May 2004; Guy Martin <gmsoft@gentoo.org> python-2.3.3-r1.ebuild,
+ python-2.3.3.ebuild, python-2.3.4_rc1.ebuild:
+ Fix os.utime() on hppa. utimes it not supported but unfortunately reported as
+ working.
*python-2.3.4_rc1 (15 May 2004)
diff --git a/dev-lang/python/python-2.3.3-r1.ebuild b/dev-lang/python/python-2.3.3-r1.ebuild
index fb99f6035eb8..7fc2681396bb 100644
--- a/dev-lang/python/python-2.3.3-r1.ebuild
+++ b/dev-lang/python/python-2.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3-r1.ebuild,v 1.6 2004/05/15 21:05:17 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3-r1.ebuild,v 1.7 2004/05/22 16:11:26 gmsoft Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -58,6 +58,8 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
epatch ${FILESDIR}/${PN}-2.3-mimetypes_apache.patch
epatch ${FILESDIR}/${PN}-2.3-db4.2.patch
+ # fix os.utime() on hppa. utimes it not supported but unfortunately reported as working - gmsoft (22 May 04)
+ [ "${ARCH}" = "hppa" ] && sed -e 's/utimes //' -i ${S}/configure
}
src_configure() {
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index 222f59d7984e..9aafb0922309 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.23 2004/04/16 02:31:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.24 2004/05/22 16:11:26 gmsoft Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -54,6 +54,8 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
epatch ${FILESDIR}/${PN}-2.3-mimetypes_apache.patch
epatch ${FILESDIR}/${PN}-2.3-db4.2.patch
+ # fix os.utime() on hppa. utimes it not supported but unfortunately reported as working - gmsoft (22 May 04)
+ [ "${ARCH}" = "hppa" ] && sed -e 's/utimes //' -i ${S}/configure
}
src_configure() {
diff --git a/dev-lang/python/python-2.3.4_rc1.ebuild b/dev-lang/python/python-2.3.4_rc1.ebuild
index bee765a55331..555c3d776175 100644
--- a/dev-lang/python/python-2.3.4_rc1.ebuild
+++ b/dev-lang/python/python-2.3.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.2 2004/05/15 21:05:17 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.3 2004/05/22 16:11:26 gmsoft Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -58,6 +58,8 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
epatch ${FILESDIR}/${PN}-2.3-mimetypes_apache.patch
epatch ${FILESDIR}/${PN}-2.3-db4.2.patch
+ # fix os.utime() on hppa. utimes it not supported but unfortunately reported as working - gmsoft (22 May 04)
+ [ "${ARCH}" = "hppa" ] && sed -e 's/utimes //' -i ${S}/configure
}
src_configure() {