summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-12 20:01:34 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-12 20:01:34 +0000
commit042a445a05679c16c1e1a0a7705d1acae7b3f7fa (patch)
treecdcecd60de5bc2b8fc21d531e5a9fce47ee00d29
parentFixed out of imagedir writes. (diff)
downloadgentoo-2-042a445a05679c16c1e1a0a7705d1acae7b3f7fa.tar.gz
gentoo-2-042a445a05679c16c1e1a0a7705d1acae7b3f7fa.tar.bz2
gentoo-2-042a445a05679c16c1e1a0a7705d1acae7b3f7fa.zip
new sh-utils with zapped /usr/bin/uptime (coming from procps pkg. now)
-rw-r--r--sys-apps/sh-utils/files/digest-sh-utils-2.0.111
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0.11.ebuild54
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild67
3 files changed, 55 insertions, 67 deletions
diff --git a/sys-apps/sh-utils/files/digest-sh-utils-2.0.11 b/sys-apps/sh-utils/files/digest-sh-utils-2.0.11
new file mode 100644
index 000000000000..612847f03783
--- /dev/null
+++ b/sys-apps/sh-utils/files/digest-sh-utils-2.0.11
@@ -0,0 +1 @@
+MD5 78ba650ef854d0b8f2bfcf12997295c2 sh-utils-2.0.11.tar.gz 1671168
diff --git a/sys-apps/sh-utils/sh-utils-2.0.11.ebuild b/sys-apps/sh-utils/sh-utils-2.0.11.ebuild
new file mode 100644
index 000000000000..147e5b402083
--- /dev/null
+++ b/sys-apps/sh-utils/sh-utils-2.0.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0.11.ebuild,v 1.1 2001/12/12 20:01:34 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Your standard GNU shell utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${P}.tar.gz"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ CFLAGS="${CFLAGS}" ./configure --host=${CHOST} --build=${CHOST} \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --without-included-regex ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ rm -rf ${D}/usr/lib
+ dodir /bin
+ cd ${D}/usr/bin
+ mv date echo false pwd stty su true uname ${D}/bin
+
+ if [ -z "`use build`" ]
+ then
+ # We must use hostname from net-base
+ rm ${D}/usr/bin/hostname
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog ChangeLog.0 NEWS README THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+ #we use the /bin/su from the sys-apps/shadow package
+ rm ${D}/bin/su
+ rm ${D}/usr/share/man/man1/su.1.gz
+ #we use the /usr/bin/uptime from the sys-apps/procps package
+ rm ${D}/usr/bin/uptime
+ rm ${D}/usr/share/man/man1/uptime.1.gz
+}
+
+
+
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
deleted file mode 100644
index bdbb8c14699a..000000000000
--- a/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild,v 1.5 2001/09/16 05:03:15 drobbins Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Your standard GNU shell utilities"
-SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-src-sys2.h-gentoo.diff
-}
-
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- CFLAGS="${CFLAGS}" try ./configure --host=${CHOST} --build=${CHOST} \
- --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
- --without-included-regex ${myconf}
-
- if [ -z "`use static`" ]
- then
- try make ${MAKEOPTS}
- else
- try make ${MAKEOPTS} LDFLAGS=-static
- fi
-}
-
-src_install() {
- try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
- rm -rf ${D}/usr/lib
- dodir /bin
- cd ${D}/usr/bin
- mv date echo false pwd stty su true uname ${D}/bin
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- # We must use hostname from net-base
- rm ${D}/usr/bin/hostname
- cd ${S}
- dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
- NEWS README THANKS TODO
- else
- rm -rf ${D}/usr/share
- fi
- #we use the /bin/su from the sys-apps/shadow package
- rm ${D}/bin/su
- rm ${D}/usr/share/man/man1/su.1.gz
-}
-
-
-