summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-06 12:01:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-06 12:01:29 +0000
commit041e27d906a8abfcbf812f2b26d82daa45a43e69 (patch)
treeb8f7f34eba2b7463f63ae9e4f3ee69d73b8d24cb
parentfix bug 125175 (diff)
downloadgentoo-2-041e27d906a8abfcbf812f2b26d82daa45a43e69.tar.gz
gentoo-2-041e27d906a8abfcbf812f2b26d82daa45a43e69.tar.bz2
gentoo-2-041e27d906a8abfcbf812f2b26d82daa45a43e69.zip
Add patch to build with GCC 4.1. Closes bug #123719.
(Portage version: 2.1_pre5-r4)
-rw-r--r--dev-util/kprof/ChangeLog8
-rw-r--r--dev-util/kprof/files/kprof-1.4.3-gcc41.patch47
-rw-r--r--dev-util/kprof/kprof-1.4.3.ebuild11
3 files changed, 58 insertions, 8 deletions
diff --git a/dev-util/kprof/ChangeLog b/dev-util/kprof/ChangeLog
index 650ede8657d6..7cdff764674c 100644
--- a/dev-util/kprof/ChangeLog
+++ b/dev-util/kprof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/kprof
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/ChangeLog,v 1.10 2005/05/07 19:13:00 carlo Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/ChangeLog,v 1.11 2006/03/06 12:01:29 flameeyes Exp $
+
+ 06 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kprof-1.4.3-gcc41.patch, kprof-1.4.3.ebuild:
+ Add patch to build with GCC 4.1. Closes bug #123719.
07 May 2005; Carsten Lohrke <carlo@gentoo.org>
+files/kprof-1.4.3-configure-arts.diff, kprof-1.4.3.ebuild:
diff --git a/dev-util/kprof/files/kprof-1.4.3-gcc41.patch b/dev-util/kprof/files/kprof-1.4.3-gcc41.patch
new file mode 100644
index 000000000000..d80cc92be2fd
--- /dev/null
+++ b/dev-util/kprof/files/kprof-1.4.3-gcc41.patch
@@ -0,0 +1,47 @@
+Index: kprof/kprof/parseprofile_fnccheck.h
+===================================================================
+--- kprof.orig/kprof/parseprofile_fnccheck.h
++++ kprof/kprof/parseprofile_fnccheck.h
+@@ -21,7 +21,10 @@
+ #include "parseprofile.h"
+ #endif
+
+-class CProfileInfo;
++#include <qvector.h>
++#include <qtextstream.h>
++#include "cprofileinfo.h"
++
+ class QString;
+
+ class CParseProfile_fnccheck : public CParseProfile
+Index: kprof/kprof/parseprofile_gprof.h
+===================================================================
+--- kprof.orig/kprof/parseprofile_gprof.h
++++ kprof/kprof/parseprofile_gprof.h
+@@ -22,7 +22,9 @@
+ #include "parseprofile.h"
+ #endif
+
+-class CProfileInfo;
++#include <qvector.h>
++#include <qtextstream.h>
++#include "cprofileinfo.h"
+
+ class CParseProfile_gprof : public CParseProfile
+ {
+Index: kprof/kprof/parseprofile_pose.h
+===================================================================
+--- kprof.orig/kprof/parseprofile_pose.h
++++ kprof/kprof/parseprofile_pose.h
+@@ -21,7 +21,10 @@
+ #include "parseprofile.h"
+ #endif
+
+-class CProfileInfo;
++#include <qvector.h>
++#include <qtextstream.h>
++#include "cprofileinfo.h"
++
+ class QString;
+
+ class CParseProfile_pose : public CParseProfile
diff --git a/dev-util/kprof/kprof-1.4.3.ebuild b/dev-util/kprof/kprof-1.4.3.ebuild
index be63449ec3c3..781a87c6fc2d 100644
--- a/dev-util/kprof/kprof-1.4.3.ebuild
+++ b/dev-util/kprof/kprof-1.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/kprof-1.4.3.ebuild,v 1.5 2005/05/07 19:13:00 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/kprof-1.4.3.ebuild,v 1.6 2006/03/06 12:01:29 flameeyes Exp $
inherit kde eutils
@@ -17,7 +17,6 @@ IUSE=""
need-kde 3
-src_unpack(){
- kde_src_unpack
- epatch ${FILESDIR}/${P}-configure-arts.diff
-}
+PATCHES="${FILESDIR}/${P}-configure-arts.diff
+ ${FILESDIR}/${P}-gcc41.patch"
+