summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2011-06-18 10:01:46 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2011-06-18 10:01:46 +0000
commit038113674882bf4a7bd775a6fa974cede522dc7c (patch)
tree7a92bd27a75e0246bc58a058e3981274ee2f1aef
parentStable on amd64 wrt bug #371975 (diff)
downloadgentoo-2-038113674882bf4a7bd775a6fa974cede522dc7c.tar.gz
gentoo-2-038113674882bf4a7bd775a6fa974cede522dc7c.tar.bz2
gentoo-2-038113674882bf4a7bd775a6fa974cede522dc7c.zip
Move to EAPI4, fix handling of ruby dependencies
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rcsparse/ChangeLog8
-rw-r--r--dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/rcsparse/ChangeLog b/dev-ruby/rcsparse/ChangeLog
index 46ac2d637019..07637a854bb5 100644
--- a/dev-ruby/rcsparse/ChangeLog
+++ b/dev-ruby/rcsparse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rcsparse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/ChangeLog,v 1.1 2011/06/15 22:01:26 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/ChangeLog,v 1.2 2011/06/18 10:01:46 sochotnicky Exp $
+
+*rcsparse-0_pre45-r1 (18 Jun 2011)
+
+ 18 Jun 2011; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +rcsparse-0_pre45-r1.ebuild:
+ Move to EAPI4, fix handling of ruby dependencies
*rcsparse-0_pre45 (15 Jun 2011)
diff --git a/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild b/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
new file mode 100644
index 000000000000..2b996dc75296
--- /dev/null
+++ b/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild,v 1.1 2011/06/18 10:01:46 sochotnicky Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+#mercurial after ruby!
+inherit ruby-ng mercurial
+
+MY_PV="${PV#0_pre}"
+
+DESCRIPTION="rcsparse ruby module"
+HOMEPAGE="http://ww2.fs.ei.tum.de/~corecode/hg/rcsparse"
+SRC_URI=""
+EHG_REPO_URI="http://ww2.fs.ei.tum.de/~corecode/hg/rcsparse"
+EHG_REVISION="${MY_PV}"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RUBY_S="${P}"
+# return S to default after ruby-ng has modified it
+S="${WORKDIR}/${RUBY_S}"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+src_prepare() {
+ # this is a workaround because combination of ruby-ng and mercurial is
+ # not working correctly for unpacking
+ for rubyv in ${USE_RUBY} all;do
+ mkdir "${WORKDIR}/${rubyv}"
+ cp -prl "${S}" "${WORKDIR}/${rubyv}/${RUBY_S}"
+ done
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test.rb || die
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install
+}