summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2012-01-17 12:55:52 +0000
committerTobias Klausmann <klausman@gentoo.org>2012-01-17 12:55:52 +0000
commit02b6c463315ad72b8fe78435a9de9c875203cb8a (patch)
tree10484fcb29f49044f9fcf247127ea5441d7e61e9
parentRemove kdeenablefinal patch. Build feature is gone. (diff)
downloadgentoo-2-02b6c463315ad72b8fe78435a9de9c875203cb8a.tar.gz
gentoo-2-02b6c463315ad72b8fe78435a9de9c875203cb8a.tar.bz2
gentoo-2-02b6c463315ad72b8fe78435a9de9c875203cb8a.zip
Make '-z defs' a linker flag explicitly (bug 395213)
(Portage version: 2.1.10.44/cvs/Linux x86_64)
-rw-r--r--media-sound/audacious/ChangeLog8
-rw-r--r--media-sound/audacious/audacious-3.1.1.ebuild9
-rw-r--r--media-sound/audacious/audacious-3.1.ebuild9
-rw-r--r--media-sound/audacious/files/audacious_ldflags.patch11
4 files changed, 31 insertions, 6 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 317ccff47ea2..84763ed604b8 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/audacious
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.248 2011/12/07 13:47:38 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.249 2012/01/17 12:55:52 klausman Exp $
+
+ 17 Jan 2012; Tobias Klausmann <klausman@gentoo.org>
+ +files/audacious_ldflags.patch, audacious-3.1.1.ebuild, audacious-3.1.ebuild:
+ Make '-z defs' a linker flag explicitly (bug 395213)
07 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> audacious-3.1.ebuild:
x86 stable wrt security bug #383991
diff --git a/media-sound/audacious/audacious-3.1.1.ebuild b/media-sound/audacious/audacious-3.1.1.ebuild
index 8cc3c5033e03..6f1b4d234bc4 100644
--- a/media-sound/audacious/audacious-3.1.1.ebuild
+++ b/media-sound/audacious/audacious-3.1.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.1.1.ebuild,v 1.1 2011/12/05 22:46:56 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.1.1.ebuild,v 1.2 2012/01/17 12:55:52 klausman Exp $
EAPI=4
+inherit eutils
MY_P="${P/_/-}"
S="${WORKDIR}/${MY_P}"
@@ -34,6 +35,10 @@ DEPEND="${RDEPEND}
PDEPEND=">=media-plugins/audacious-plugins-3.1.1"
src_configure() {
+ # Some gccs don't like "-z defs" on their command line. Explicitly make it a
+ # linker flag (bug 395213).
+ epatch "${FILESDIR}/audacious_ldflags.patch"
+
# D-Bus is a mandatory dependency, remote control,
# session management and some plugins depend on this.
# Building without D-Bus is *unsupported* and a USE-flag
diff --git a/media-sound/audacious/audacious-3.1.ebuild b/media-sound/audacious/audacious-3.1.ebuild
index 6f7278e8c88b..083f9fdfd9c4 100644
--- a/media-sound/audacious/audacious-3.1.ebuild
+++ b/media-sound/audacious/audacious-3.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.1.ebuild,v 1.4 2011/12/07 13:47:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.1.ebuild,v 1.5 2012/01/17 12:55:52 klausman Exp $
EAPI=4
+inherit eutils
MY_P="${P/_/-}"
S="${WORKDIR}/${MY_P}"
@@ -34,6 +35,10 @@ DEPEND="${RDEPEND}
PDEPEND=">=media-plugins/audacious-plugins-3.1"
src_configure() {
+ # Some gccs don't like "-z defs" on their command line. Explicitly make it a
+ # linker flag (bug 395213).
+ epatch "${FILESDIR}/audacious_ldflags.patch"
+
# D-Bus is a mandatory dependency, remote control,
# session management and some plugins depend on this.
# Building without D-Bus is *unsupported* and a USE-flag
diff --git a/media-sound/audacious/files/audacious_ldflags.patch b/media-sound/audacious/files/audacious_ldflags.patch
new file mode 100644
index 000000000000..e030b1af5dae
--- /dev/null
+++ b/media-sound/audacious/files/audacious_ldflags.patch
@@ -0,0 +1,11 @@
+--- configure.old 2012-01-17 12:41:09.000000000 +0000
++++ configure 2012-01-17 12:41:42.000000000 +0000
+@@ -4759,7 +4759,7 @@
+ *linux*)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+- LDFLAGS="$LDFLAGS -z defs"
++ LDFLAGS="$LDFLAGS -Wl,-z,defs"
+ ;;
+ *)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5