summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-06-18 06:41:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-06-18 06:41:08 +0000
commit0112dcb4c74c27d160829ef5f6e9d88f8899fd0c (patch)
tree23911ad36a2f49275059df4595aa5ccb1e00dbc9
parentUse correct temporary build directory for live builds. (diff)
downloadgentoo-2-0112dcb4c74c27d160829ef5f6e9d88f8899fd0c.tar.gz
gentoo-2-0112dcb4c74c27d160829ef5f6e9d88f8899fd0c.tar.bz2
gentoo-2-0112dcb4c74c27d160829ef5f6e9d88f8899fd0c.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/testfixtures/ChangeLog7
-rw-r--r--dev-python/testfixtures/testfixtures-4.1.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/testfixtures/ChangeLog b/dev-python/testfixtures/ChangeLog
index f68c9bdba3eb..b669014d0529 100644
--- a/dev-python/testfixtures/ChangeLog
+++ b/dev-python/testfixtures/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testfixtures
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.13 2015/06/04 07:10:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.14 2015/06/18 06:41:08 patrick Exp $
+
+*testfixtures-4.1.2 (18 Jun 2015)
+
+ 18 Jun 2015; Patrick Lauer <patrick@gentoo.org> +testfixtures-4.1.2.ebuild:
+ Bump
04 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/testfixtures/testfixtures-4.1.2.ebuild b/dev-python/testfixtures/testfixtures-4.1.2.ebuild
new file mode 100644
index 000000000000..fad149b2389d
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-4.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-4.1.2.ebuild,v 1.1 2015/06/18 06:41:08 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="http://pypi.python.org/pypi/testfixtures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy ) )
+ test? ( dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/nose_fixes[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_prepare_all() {
+ # Makefile comes set pointing at a wrong location
+ sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests ${PN}/tests || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}