summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-25 21:21:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-25 21:21:26 +0000
commit22a7f1170152421af4e3686079f6c5fb62e9010b (patch)
tree5a7be175b1d9e70ded7bd932cc5677b62e174f99
parentgcc/7.3.0: initial patchset, take 2 (moved patches to gentoo/) (diff)
downloadgentoo-22a7f1170152421af4e3686079f6c5fb62e9010b.tar.gz
gentoo-22a7f1170152421af4e3686079f6c5fb62e9010b.tar.bz2
gentoo-22a7f1170152421af4e3686079f6c5fb62e9010b.zip
gcc/7.3.0: initial patchset, take 2 (moved patches to gentoo/)
-rw-r--r--src/patchsets/gcc/7.3.0/10_all_default-fortify-source.patch15
-rw-r--r--src/patchsets/gcc/7.3.0/11_all_default-warn-format-security.patch22
-rw-r--r--src/patchsets/gcc/7.3.0/12_all_default-warn-trampolines.patch13
-rw-r--r--src/patchsets/gcc/7.3.0/13_all_default-ssp-fix.patch54
-rw-r--r--src/patchsets/gcc/7.3.0/25_all_alpha-mieee-default.patch39
-rw-r--r--src/patchsets/gcc/7.3.0/34_all_ia64_note.GNU-stack.patch92
-rw-r--r--src/patchsets/gcc/7.3.0/50_all_libiberty-asprintf.patch18
-rw-r--r--src/patchsets/gcc/7.3.0/51_all_libiberty-pic.patch10
-rw-r--r--src/patchsets/gcc/7.3.0/54_all_nopie-all-flags.patch18
-rw-r--r--src/patchsets/gcc/7.3.0/55_all_extra-options.patch87
-rw-r--r--src/patchsets/gcc/7.3.0/90_all_pr55930-dependency-tracking.patch18
-rw-r--r--src/patchsets/gcc/7.3.0/README.history12
12 files changed, 0 insertions, 398 deletions
diff --git a/src/patchsets/gcc/7.3.0/10_all_default-fortify-source.patch b/src/patchsets/gcc/7.3.0/10_all_default-fortify-source.patch
deleted file mode 100644
index 36c576211d..0000000000
--- a/src/patchsets/gcc/7.3.0/10_all_default-fortify-source.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Enable -D_FORTIFY_SOURCE=2 by default.
-
-
---- a/gcc/c-family/c-cppbuiltin.c
-+++ b/gcc/c-family/c-cppbuiltin.c
-@@ -951,6 +951,9 @@ c_cpp_builtins (cpp_reader *pfile)
- builtin_define_with_value ("__REGISTER_PREFIX__", REGISTER_PREFIX, 0);
- builtin_define_with_value ("__USER_LABEL_PREFIX__", user_label_prefix, 0);
-
-+ /* Fortify Source enabled by default w/optimization. */
-+ cpp_define (pfile, "_FORTIFY_SOURCE=((defined __OPTIMIZE__ && __OPTIMIZE__ > 0) ? 2 : 0)");
-+
- /* Misc. */
- if (flag_gnu89_inline)
- cpp_define (pfile, "__GNUC_GNU_INLINE__");
diff --git a/src/patchsets/gcc/7.3.0/11_all_default-warn-format-security.patch b/src/patchsets/gcc/7.3.0/11_all_default-warn-format-security.patch
deleted file mode 100644
index 8994654afb..0000000000
--- a/src/patchsets/gcc/7.3.0/11_all_default-warn-format-security.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Enable -Wformat and -Wformat-security by default.
-
---- a/gcc/c-family/c.opt 2016-03-23 18:51:56.000000000 +0100
-+++ b/gcc/c-family/c.opt 2016-04-28 23:45:54.063351272 +0200
-@@ -459,7 +459,7 @@ C ObjC C++ ObjC++ Var(warn_format_nonlit
- Warn about format strings that are not literals.
-
- Wformat-security
--C ObjC C++ ObjC++ Var(warn_format_security) Warning LangEnabledBy(C ObjC C++ ObjC++,Wformat=, warn_format >= 2, 0)
-+C ObjC C++ ObjC++ Var(warn_format_security) Init(1) Warning LangEnabledBy(C ObjC C++ ObjC++,Wformat=, warn_format >= 2, 0)
- Warn about possible security problems with format functions.
-
- Wformat-signedness
-@@ -475,7 +475,7 @@ C ObjC C++ ObjC++ Var(warn_format_zero_l
- Warn about zero-length formats.
-
- Wformat=
--C ObjC C++ ObjC++ Joined RejectNegative UInteger Var(warn_format) Warning LangEnabledBy(C ObjC C++ ObjC++,Wall, 1, 0)
-+C ObjC C++ ObjC++ Joined RejectNegative UInteger Var(warn_format) Init(1) Warning LangEnabledBy(C ObjC C++ ObjC++,Wall, 1, 0)
- Warn about printf/scanf/strftime/strfmon format string anomalies.
-
- Wignored-qualifiers
diff --git a/src/patchsets/gcc/7.3.0/12_all_default-warn-trampolines.patch b/src/patchsets/gcc/7.3.0/12_all_default-warn-trampolines.patch
deleted file mode 100644
index 7a644cb1e1..0000000000
--- a/src/patchsets/gcc/7.3.0/12_all_default-warn-trampolines.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Enable -Wtrampolines by default.
-
---- a/gcc/common.opt
-+++ b/gcc/common.opt
-@@ -712,7 +712,7 @@ Common Var(warn_system_headers) Warning
- Do not suppress warnings from system headers.
-
- Wtrampolines
--Common Var(warn_trampolines) Warning
-+Common Var(warn_trampolines) Init(1) Warning
- Warn whenever a trampoline is generated.
-
- Wtype-limits
diff --git a/src/patchsets/gcc/7.3.0/13_all_default-ssp-fix.patch b/src/patchsets/gcc/7.3.0/13_all_default-ssp-fix.patch
deleted file mode 100644
index d5672974c5..0000000000
--- a/src/patchsets/gcc/7.3.0/13_all_default-ssp-fix.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-We disable ssp on -nostdlib and -ffreestanding as we did on older gcc
-and change the buffer size.
-
---- a/gcc/c-family/c-opts.c
-+++ b/gcc/c-family/c-opts.c
-@@ -450,7 +450,14 @@
-
- case OPT_ffreestanding:
- value = !value;
-+ if (global_options.x_flag_stack_protect == -1)
-+ global_options.x_flag_stack_protect = 0;
- /* Fall through. */
-+
-+ case OPT_nostdlib:
-+ if (global_options.x_flag_stack_protect == -1)
-+ global_options.x_flag_stack_protect = 0;
-+
- case OPT_fhosted:
- flag_hosted = value;
- flag_no_builtin = !value;
---- a/gcc/c-family/c.opt
-+++ b/gcc/c-family/c.opt
-@@ -1647,6 +1647,10 @@ nostdinc++
- C++ ObjC++
- Do not search standard system include directories for C++.
-
-+nostdlib
-+C ObjC C++ ObjC++
-+; Documented in common.opt
-+
- o
- C ObjC C++ ObjC++ Joined Separate
- ; Documented in common.opt
---- a/gcc/gcc.c
-+++ b/gcc/gcc.c
-@@ -1145,6 +1145,7 @@
- %{-help=*:--help=%*}\
- %{!fsyntax-only:%{S:%W{o*}%{!o*:-o %b.s}}}\
- %{fsyntax-only:-o %j} %{-param*}\
-+ %{nostdlib:-nostdlib}\
- %{coverage:-fprofile-arcs -ftest-coverage}\
- %{fprofile-arcs|fprofile-generate*|coverage:\
- %{!fprofile-update=single:\
---- a/gcc/params.def
-+++ b/gcc/params.def
-@@ -673,7 +673,7 @@ DEFPARAM (PARAM_INTEGER_SHARE_LIMIT,
- DEFPARAM (PARAM_SSP_BUFFER_SIZE,
- "ssp-buffer-size",
- "The lower bound for a buffer to be considered for stack smashing protection.",
-- 8, 1, 0)
-+ 4, 1, 0)
-
- DEFPARAM (PARAM_MIN_SIZE_FOR_STACK_SHARING,
- "min-size-for-stack-sharing",
diff --git a/src/patchsets/gcc/7.3.0/25_all_alpha-mieee-default.patch b/src/patchsets/gcc/7.3.0/25_all_alpha-mieee-default.patch
deleted file mode 100644
index b266d773be..0000000000
--- a/src/patchsets/gcc/7.3.0/25_all_alpha-mieee-default.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Set the default behavior on alpha to use -mieee since the large majority of
-time we want this (bad/weird things can happen with packages built without
-it).
-
-To satisfy those people who may not want -mieee forced on them all the time,
-we also provide -mno-ieee.
-
-Patch by Mike Frysinger <vapier@gentoo.org>
-
-Note: upstream doesn't want to take this due to long standing behavior, and
-because it'd make behavior across OS's inconsistent:
- https://gcc.gnu.org/ml/gcc-patches/2003-07/msg02144.html
-
-This makes sense for upstream, but Gentoo is more concerned about packages
-behaving the same across arches under Linux.
-
---- a/gcc/config/alpha/alpha.h
-+++ b/gcc/config/alpha/alpha.h
-@@ -96,6 +96,8 @@ along with GCC; see the file COPYING3. If not see
- while (0)
- #endif
-
-+#define CPP_SPEC "%{!no-ieee:-mieee}"
-+
- /* Run-time compilation parameters selecting different hardware subsets. */
-
- /* Which processor to schedule for. The cpu attribute defines a list that
---- a/gcc/config/alpha/alpha.opt
-+++ b/gcc/config/alpha/alpha.opt
-@@ -35,7 +35,7 @@
- Request IEEE-conformant math library routines (OSF/1).
-
- mieee
--Target Report RejectNegative Mask(IEEE)
-+Target Report Mask(IEEE)
- Emit IEEE-conformant code, without inexact exceptions.
-
- mieee-with-inexact
-
diff --git a/src/patchsets/gcc/7.3.0/34_all_ia64_note.GNU-stack.patch b/src/patchsets/gcc/7.3.0/34_all_ia64_note.GNU-stack.patch
deleted file mode 100644
index 66a787e1b2..0000000000
--- a/src/patchsets/gcc/7.3.0/34_all_ia64_note.GNU-stack.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-http://gcc.gnu.org/PR21098
-
-
-2004-09-20 Jakub Jelinek <jakub@redhat.com>
-
- * config/rs6000/ppc-asm.h: Add .note.GNU-stack section also
- on ppc64-linux.
-
- * config/ia64/lib1funcs.asm: Add .note.GNU-stack section on
- ia64-linux.
- * config/ia64/crtbegin.asm: Likewise.
- * config/ia64/crtend.asm: Likewise.
- * config/ia64/crti.asm: Likewise.
- * config/ia64/crtn.asm: Likewise.
-
-2004-05-14 Jakub Jelinek <jakub@redhat.com>
-
- * config/ia64/linux.h (TARGET_ASM_FILE_END): Define.
-
-
---- a/gcc/config/ia64/linux.h
-+++ b/gcc/config/ia64/linux.h
-@@ -24,6 +24,8 @@ a copy of the GCC Runtime Library Exception along with this program;
- see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
- <http://www.gnu.org/licenses/>. */
-
-+#define TARGET_ASM_FILE_END file_end_indicate_exec_stack
-+
- /* This is for -profile to use -lc_p instead of -lc. */
- #undef CC1_SPEC
- #define CC1_SPEC "%{profile:-p} %{G*}"
---- a/gcc/config/rs6000/ppc-asm.h
-+++ b/gcc/config/rs6000/ppc-asm.h
-@@ -352,7 +352,7 @@ GLUE(.L,name): \
- #endif
- #endif
-
--#if defined __linux__ && !defined __powerpc64__
-+#if defined __linux__
- .section .note.GNU-stack
- .previous
- #endif
---- a/libgcc/config/ia64/crtbegin.S
-+++ b/libgcc/config/ia64/crtbegin.S
-@@ -252,3 +252,7 @@ __do_jv_register_classes:
- .weak __cxa_finalize
- #endif
- .weak _Jv_RegisterClasses
-+
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
---- a/libgcc/config/ia64/crtend.S
-+++ b/libgcc/config/ia64/crtend.S
-@@ -119,3 +119,6 @@ __do_global_ctors_aux:
-
- br.ret.sptk.many rp
- .endp __do_global_ctors_aux
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
---- a/libgcc/config/ia64/crti.S
-+++ b/libgcc/config/ia64/crti.S
-@@ -49,5 +49,8 @@ _fini:
- .save rp, r33
- mov r33 = b0
- .body
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-
- # end of crti.S
---- a/libgcc/config/ia64/crtn.S
-+++ b/libgcc/config/ia64/crtn.S
-@@ -39,5 +39,8 @@
- .restore sp
- mov r12 = r35
- br.ret.sptk.many b0
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-
- # end of crtn.S
---- a/libgcc/config/ia64/lib1funcs.S
-+++ b/libgcc/config/ia64/lib1funcs.S
-@@ -793,3 +793,6 @@ __floattitf:
- .endp __floattitf
- #endif
- #endif
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
diff --git a/src/patchsets/gcc/7.3.0/50_all_libiberty-asprintf.patch b/src/patchsets/gcc/7.3.0/50_all_libiberty-asprintf.patch
deleted file mode 100644
index bee0c4c237..0000000000
--- a/src/patchsets/gcc/7.3.0/50_all_libiberty-asprintf.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-2008-07-25 Magnus Granberg <zorry@ume.nu>
-
- * include/libiberty.h (asprintf): Don't declare if defined as a macro
-
---- a/include/libiberty.h
-+++ b/include/libiberty.h
-@@ -609,8 +609,11 @@ extern int pwait (int, int *, int);
- /* Like sprintf but provides a pointer to malloc'd storage, which must
- be freed by the caller. */
-
-+/* asprintf may be declared as a macro by glibc with __USE_FORTIFY_LEVEL. */
-+#ifndef asprintf
- extern int asprintf (char **, const char *, ...) ATTRIBUTE_PRINTF_2;
- #endif
-+#endif
-
- #if !HAVE_DECL_VASPRINTF
- /* Like vsprintf but provides a pointer to malloc'd storage, which
diff --git a/src/patchsets/gcc/7.3.0/51_all_libiberty-pic.patch b/src/patchsets/gcc/7.3.0/51_all_libiberty-pic.patch
deleted file mode 100644
index b6160a7307..0000000000
--- a/src/patchsets/gcc/7.3.0/51_all_libiberty-pic.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/libiberty/Makefile.in
-+++ b/libiberty/Makefile.in
-@@ -246,6 +246,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
- $(AR) $(AR_FLAGS) $(TARGETLIB) \
- $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
- $(RANLIB) $(TARGETLIB); \
-+ cp $(TARGETLIB) ../ ; \
- cd ..; \
- else true; fi
-
diff --git a/src/patchsets/gcc/7.3.0/54_all_nopie-all-flags.patch b/src/patchsets/gcc/7.3.0/54_all_nopie-all-flags.patch
deleted file mode 100644
index 48536e607c..0000000000
--- a/src/patchsets/gcc/7.3.0/54_all_nopie-all-flags.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-We need to pass NO_PIE_CFLAGS to ALL_* so gcc don't fail when
-we compile it with older gcc and pie.
-
---- a/gcc/Makefile.in 2015-06-25 19:18:12.000000000 +0200
-+++ b/gcc/Makefile.in 2016-04-22 00:12:54.029178860 +0200
-@@ -991,10 +991,10 @@ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@)
- ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS)
-
- # This is the variable to use when using $(COMPILER).
--ALL_COMPILERFLAGS = $(ALL_CXXFLAGS)
-+ALL_COMPILERFLAGS = $(NO_PIE_CFLAGS) $(ALL_CXXFLAGS)
-
- # This is the variable to use when using $(LINKER).
--ALL_LINKERFLAGS = $(ALL_CXXFLAGS)
-+ALL_LINKERFLAGS = $(NO_PIE_CFLAGS) $(ALL_CXXFLAGS)
-
- # Build and host support libraries.
-
diff --git a/src/patchsets/gcc/7.3.0/55_all_extra-options.patch b/src/patchsets/gcc/7.3.0/55_all_extra-options.patch
deleted file mode 100644
index ff14c100ca..0000000000
--- a/src/patchsets/gcc/7.3.0/55_all_extra-options.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-On Hardened we add or remove some options like -fstack-check,
--fstack-protector-all, -fstrict_overflow and -z now
-
---- a/libgcc/Makefile.in 2011-11-22 04:01:02.000000000 +0100
-+++ b/libgcc/Makefile.in 2011-12-25 15:18:22.449610631 +0100
-@@ -225,7 +225,7 @@ endif
- LIBGCC2_DEBUG_CFLAGS = -g
- LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(HOST_LIBGCC2_CFLAGS) \
- $(LIBGCC2_DEBUG_CFLAGS) -DIN_LIBGCC2 \
-- -fbuilding-libgcc -fno-stack-protector \
-+ -fbuilding-libgcc -fno-stack-protector -fstack-check=no \
- $(INHIBIT_LIBC_CFLAGS)
-
- # Additional options to use when compiling libgcc2.a.
-@@ -279,7 +290,7 @@ INTERNAL_CFLAGS = $(CFLAGS) $(LIBGCC2_CF
- -finhibit-size-directive -fno-inline -fno-exceptions \
- -fno-zero-initialized-in-bss -fno-toplevel-reorder -fno-tree-vectorize \
- -fbuilding-libgcc -fno-stack-protector $(FORCE_EXPLICIT_EH_REGISTRY) \
-- $(INHIBIT_LIBC_CFLAGS)
-+ -fstack-check=no $(INHIBIT_LIBC_CFLAGS)
-
- # Extra flags to use when compiling crt{begin,end}.o.
- CRTSTUFF_T_CFLAGS =
---- a/gcc/defaults.h 2016-01-04 15:30:50.000000000 +0100
-+++ b/gcc/defaults.h 2016-05-02 22:23:43.815707806 +0200
-@@ -1398,8 +1398,12 @@ see the files COPYING3 and COPYING.RUNTI
- /* Default value for flag_stack_protect when flag_stack_protect is initialized to -1:
- --enable-default-ssp: Default flag_stack_protect to -fstack-protector-strong.
- --disable-default-ssp: Default flag_stack_protect to 0.
-+ Hardened: Default flag_stack_protect to -fstack-protector-all.
- */
- #ifdef ENABLE_DEFAULT_SSP
-+# ifdef EXTRA_OPTIONS
-+# define DEFAULT_FLAG_SSP 2
-+# endif
- # ifndef DEFAULT_FLAG_SSP
- # define DEFAULT_FLAG_SSP 3
- # endif
---- a/gcc/gcc.c 2016-02-19 23:18:38.000000000 +0100
-+++ b/gcc/gcc.c 2016-05-02 22:56:10.185721270 +0200
-@@ -868,6 +868,13 @@ proper position among the other output f
- #endif
- #endif
-
-+#define STACK_CHECK_SPEC "%{fstack-check|fstack-check=*:;: -fstack-check} "
-+#ifdef EXTRA_OPTIONS
-+#define LINK_NOW_SPEC "%{!nonow:-z now} "
-+#else
-+#define LINK_NOW_SPEC ""
-+#endif
-+
- #ifdef ENABLE_DEFAULT_PIE
- #define NO_PIE_SPEC "no-pie|static"
- #define PIE_SPEC NO_PIE_SPEC "|r|shared:;"
-@@ -1013,7 +1020,7 @@ proper position among the other output f
- %(linker) " \
- LINK_PLUGIN_SPEC \
- "%{flto|flto=*:%<fcompare-debug*} \
-- %{flto} %{fno-lto} %{flto=*} %l " LINK_PIE_SPEC \
-+ %{flto} %{fno-lto} %{flto=*} %l " LINK_PIE_SPEC LINK_NOW_SPEC \
- "%{fuse-ld=*:-fuse-ld=%*} " LINK_COMPRESS_DEBUG_SPEC \
- "%X %{o*} %{e*} %{N} %{n} %{r}\
- %{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}} \
-@@ -1052,7 +1059,11 @@ proper position among the other output f
-
- static const char *asm_debug = ASM_DEBUG_SPEC;
- static const char *cpp_spec = CPP_SPEC;
-+#ifdef EXTRA_OPTIONS
-+static const char *cc1_spec = CC1_SPEC STACK_CHECK_SPEC;
-+#else
- static const char *cc1_spec = CC1_SPEC;
-+#endif
- static const char *cc1plus_spec = CC1PLUS_SPEC;
- static const char *link_gcc_c_sequence_spec = LINK_GCC_C_SEQUENCE_SPEC;
- static const char *link_ssp_spec = LINK_SSP_SPEC;
---- a/gcc/opts.c 2016-03-17 16:11:35.000000000 +0100
-+++ b/gcc/opts.c 2016-04-27 16:48:59.952580580 +0200
-@@ -495,7 +495,9 @@ static const struct default_options defa
- { OPT_LEVELS_2_PLUS, OPT_fschedule_insns2, NULL, 1 },
- #endif
- { OPT_LEVELS_2_PLUS, OPT_fstrict_aliasing, NULL, 1 },
-+#ifndef EXTRA_OPTIONS
- { OPT_LEVELS_2_PLUS, OPT_fstrict_overflow, NULL, 1 },
-+#endif
- { OPT_LEVELS_2_PLUS_SPEED_ONLY, OPT_freorder_blocks_algorithm_, NULL,
- REORDER_BLOCKS_ALGORITHM_STC },
- { OPT_LEVELS_2_PLUS, OPT_freorder_functions, NULL, 1 },
diff --git a/src/patchsets/gcc/7.3.0/90_all_pr55930-dependency-tracking.patch b/src/patchsets/gcc/7.3.0/90_all_pr55930-dependency-tracking.patch
deleted file mode 100644
index a8743e08c4..0000000000
--- a/src/patchsets/gcc/7.3.0/90_all_pr55930-dependency-tracking.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-libatomic build failure if configured with --disable-dependency-tracking
-load_n.c:115:1: fatal error: opening dependency file .deps/load_1_.lo.Ppo: No such file or directory
-
-https://bugs.gentoo.org/463463
-http://gcc.gnu.org/PR55930
-
---- a/libatomic/Makefile.in
-+++ b/libatomic/Makefile.in
-@@ -298,7 +298,8 @@ PAT_N = $(word 2,$(PAT_SPLIT))
- PAT_S = $(word 3,$(PAT_SPLIT))
- IFUNC_DEF = -DIFUNC_ALT=$(PAT_S)
- IFUNC_OPT = $(word $(PAT_S),$(IFUNC_OPTIONS))
--M_DEPS = -MT $@ -MD -MP -MF $(DEPDIR)/$(@F).Ppo
-+@AMDEP_TRUE@M_DEPS = -MT $@ -MD -MP -MF $(DEPDIR)/$(@F).Ppo
-+@AMDEP_FALSE@M_DEPS =
- M_SIZE = -DN=$(PAT_N)
- M_IFUNC = $(if $(PAT_S),$(IFUNC_DEF) $(IFUNC_OPT))
- M_FILE = $(PAT_BASE)_n.c
diff --git a/src/patchsets/gcc/7.3.0/README.history b/src/patchsets/gcc/7.3.0/README.history
deleted file mode 100644
index 4283957cc8..0000000000
--- a/src/patchsets/gcc/7.3.0/README.history
+++ /dev/null
@@ -1,12 +0,0 @@
-1.0 25 Jan 2018
- + 10_all_default-fortify-source.patch
- + 11_all_default-warn-format-security.patch
- + 12_all_default-warn-trampolines.patch
- + 13_all_default-ssp-fix.patch
- + 25_all_alpha-mieee-default.patch
- + 34_all_ia64_note.GNU-stack.patch
- + 50_all_libiberty-asprintf.patch
- + 51_all_libiberty-pic.patch
- + 54_all_nopie-all-flags.patch
- + 55_all_extra-options.patch
- + 90_all_pr55930-dependency-tracking.patch