From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 net-misc/dcetest/Manifest           |  1 +
 net-misc/dcetest/dcetest-2.0.ebuild | 31 +++++++++++++++++++++++++++++++
 net-misc/dcetest/metadata.xml       | 21 +++++++++++++++++++++
 3 files changed, 53 insertions(+)
 create mode 100644 net-misc/dcetest/Manifest
 create mode 100644 net-misc/dcetest/dcetest-2.0.ebuild
 create mode 100644 net-misc/dcetest/metadata.xml

(limited to 'net-misc/dcetest')

diff --git a/net-misc/dcetest/Manifest b/net-misc/dcetest/Manifest
new file mode 100644
index 000000000000..e880c0b7750e
--- /dev/null
+++ b/net-misc/dcetest/Manifest
@@ -0,0 +1 @@
+DIST dcetest.tar 133120 RMD160 d3d0d3a1e55072f42094e95e3410c305701c66ae SHA1 1f330411fc729dbc1980ec0720e174a452c12f0e SHA256 4333d421c941d6b48df6307e2796b222ddd745db69e345f2a299af1babe04408
diff --git a/net-misc/dcetest/dcetest-2.0.ebuild b/net-misc/dcetest/dcetest-2.0.ebuild
new file mode 100644
index 000000000000..ea56dd5b7438
--- /dev/null
+++ b/net-misc/dcetest/dcetest-2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="dcetest is a clone of the Windows rpcinfo"
+HOMEPAGE="http://www.atstake.com/research/tools/info_gathering/"
+SRC_URI="http://www.atstake.com/research/tools/info_gathering/dcetest.tar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+DEPEND="sys-apps/sed"
+RDEPEND=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+	# cleanup the makefile a little
+	sed -e '/^CC/d' -i Makefile
+	sed -e 's/CFLAGS.*/CFLAGS += -Wall -funsigned-char -fPIC/g' -i Makefile
+}
+
+src_compile() {
+	emake || die
+}
+
+src_install() {
+	dobin dcetest || die
+	dodoc CHANGELOG README VERSION nt4sp6adefault.txt out out.txt out2.txt w2ksp0.txt
+}
diff --git a/net-misc/dcetest/metadata.xml b/net-misc/dcetest/metadata.xml
new file mode 100644
index 000000000000..dc267bfe85d6
--- /dev/null
+++ b/net-misc/dcetest/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+  <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription>This little utility dumps MSRPC endpoint information from
+    Windows systems. Similar to the rpcdump program from Microsoft, but does
+    not need a DCE stack and so runs on Unixes. dcetest can be very useful once
+    inside a DMZ to fingerprint Windows machines on the network. dcetest
+    operates over TCP port 135. (Think of it as rpcinfo -p against
+    Windows.)
+</longdescription>
+<longdescription lang="ja">
+これは Windows システムからの MSRPC エンドポイント情報をダンプする小さな
+ユーティリティです。Microsoft 社の rpcdump プログラムに似ていますが、DCE
+スタックを必要とせず、何より Unix 系で動きます。Dcetest は DMZ 内の 
+Windows マシンの指紋を一度に取るのに便利です。Dcetest はポート番号135で
+作動します。(Windows マシンへ向けて rpcinfo -p を実行したと考えます)
+</longdescription>
+</pkgmetadata>
-- 
cgit v1.2.3-65-gdbad