From 76bf1c12fa3aedcd336e9eff02e114f4f5abdd8b Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Wed, 5 Dec 2018 23:49:00 +0100
Subject: dev-qt/qtlocation: Add USE-DEPEND on dev-qt/qtpositioning[qml]
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

For usage of QtPositioningQuick.

While location-labs-plugin is optional, declarativemaps is built and depends on
QtPositioningQuick unconditionally. It is probably for this reason that ${PN}
already unconditionally depends on dev-qt/qtdeclarative, so making the plugin
optional would save us nothing.

Bug: https://bugs.gentoo.org/669608
Reported-by: Toralf Förster <toralf@gentoo.org>
Thanks-to: Jimi Huotari <chiitoo@gentoo.org>
Thanks-to: Iade Gesso <iade.gesso@gmail.com>
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
 dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild | 44 +++++++++++++++++++++++++++
 dev-qt/qtlocation/qtlocation-5.11.3.ebuild    | 44 ---------------------------
 2 files changed, 44 insertions(+), 44 deletions(-)
 create mode 100644 dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild
 delete mode 100644 dev-qt/qtlocation/qtlocation-5.11.3.ebuild

(limited to 'dev-qt/qtlocation')

diff --git a/dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild b/dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild
new file mode 100644
index 000000000000..78057b719907
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="The Location module for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+	KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+	~dev-qt/qtcore-${PV}
+	~dev-qt/qtdeclarative-${PV}
+	~dev-qt/qtgui-${PV}
+	~dev-qt/qtnetwork-${PV}
+	~dev-qt/qtpositioning-${PV}[qml]
+	~dev-qt/qtsql-${PV}
+	sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+	~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+	src/3rdparty/clipper
+	src/3rdparty/poly2tri
+	src/3rdparty/clip2tri
+	src/3rdparty/mapbox-gl-native
+	src/location
+	src/imports/location
+	src/plugins/geoservices
+)
+
+src_configure() {
+	# src/plugins/geoservices requires files that are only generated when
+	# qmake is run in the root directory. Bug 633776.
+	mkdir -p "${QT5_BUILD_DIR}" || die
+	qt5_qmake "${QT_BUILD_DIR}"
+	qt5-build_src_configure
+}
diff --git a/dev-qt/qtlocation/qtlocation-5.11.3.ebuild b/dev-qt/qtlocation/qtlocation-5.11.3.ebuild
deleted file mode 100644
index b6f3af24dda4..000000000000
--- a/dev-qt/qtlocation/qtlocation-5.11.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit qt5-build
-
-DESCRIPTION="The Location module for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
-	KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-IUSE=""
-
-RDEPEND="
-	~dev-qt/qtcore-${PV}
-	~dev-qt/qtdeclarative-${PV}
-	~dev-qt/qtgui-${PV}
-	~dev-qt/qtnetwork-${PV}
-	~dev-qt/qtpositioning-${PV}
-	~dev-qt/qtsql-${PV}
-	sys-libs/zlib
-"
-DEPEND="${RDEPEND}
-	~dev-qt/qtconcurrent-${PV}
-"
-
-QT5_TARGET_SUBDIRS=(
-	src/3rdparty/clipper
-	src/3rdparty/poly2tri
-	src/3rdparty/clip2tri
-	src/3rdparty/mapbox-gl-native
-	src/location
-	src/imports/location
-	src/plugins/geoservices
-)
-
-src_configure() {
-	# src/plugins/geoservices requires files that are only generated when
-	# qmake is run in the root directory. Bug 633776.
-	mkdir -p "${QT5_BUILD_DIR}" || die
-	qt5_qmake "${QT_BUILD_DIR}"
-	qt5-build_src_configure
-}
-- 
cgit v1.2.3-65-gdbad