From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 dev-python/retry-decorator/Manifest                |  1 +
 dev-python/retry-decorator/metadata.xml            |  8 ++++++++
 .../retry-decorator/retry-decorator-1.0.0.ebuild   | 23 ++++++++++++++++++++++
 3 files changed, 32 insertions(+)
 create mode 100644 dev-python/retry-decorator/Manifest
 create mode 100644 dev-python/retry-decorator/metadata.xml
 create mode 100644 dev-python/retry-decorator/retry-decorator-1.0.0.ebuild

(limited to 'dev-python/retry-decorator')

diff --git a/dev-python/retry-decorator/Manifest b/dev-python/retry-decorator/Manifest
new file mode 100644
index 000000000000..4363abae596e
--- /dev/null
+++ b/dev-python/retry-decorator/Manifest
@@ -0,0 +1 @@
+DIST retry-decorator-1.0.0.tar.gz 2835 SHA256 95b8861166e162e5259e798eb259217c59bdb8b21f055fd7f5bb4b7686fb5eae SHA512 f650740dd6d05010b7418b4d5ae7351058eb4418dabf7329390eaacceb72db60363bae8ff0bb15284301f0b5bfd9bfb731e71fdffb7231065a4db7ed6ce86da2 WHIRLPOOL ac40c8276423d9ad50e1b46d1981dae0c61e15309d1d217c4064fd0649b4fcaed940d1fd736c7a74da8757ecdfc87debe45bd21310549d35809e0da1d7da57fd
diff --git a/dev-python/retry-decorator/metadata.xml b/dev-python/retry-decorator/metadata.xml
new file mode 100644
index 000000000000..d8910af20cf0
--- /dev/null
+++ b/dev-python/retry-decorator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>python</herd>
+  <upstream>
+    <remote-id type="github">pnpnpn/retry-decorator</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/retry-decorator/retry-decorator-1.0.0.ebuild b/dev-python/retry-decorator/retry-decorator-1.0.0.ebuild
new file mode 100644
index 000000000000..4751a2178503
--- /dev/null
+++ b/dev-python/retry-decorator/retry-decorator-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Decorator for retrying when exceptions occur"
+HOMEPAGE="https://github.com/pnpnpn/retry-decorator"
+SRC_URI="https://github.com/pnpnpn/retry-decorator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+	dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst )
-- 
cgit v1.2.3-65-gdbad