From d1be71e57904a039d136e917c6f4fb93ae3284eb Mon Sep 17 00:00:00 2001
From: Justin Lecher <jlec@gentoo.org>
Date: Mon, 1 Feb 2016 17:04:31 +0100
Subject: dev-python/networkx: Version Bump

Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <jlec@gentoo.org>
---
 dev-python/networkx/Manifest             |  1 +
 dev-python/networkx/networkx-1.11.ebuild | 73 ++++++++++++++++++++++++++++++++
 2 files changed, 74 insertions(+)
 create mode 100644 dev-python/networkx/networkx-1.11.ebuild

(limited to 'dev-python/networkx')

diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 1dd881b5d1be..cbfebe2afe2b 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,2 +1,3 @@
 DIST networkx-1.10.tar.gz 1189291 SHA256 ced4095ab83b7451cec1172183eff419ed32e21397ea4e1971d92a5808ed6fb8 SHA512 fc0a0b929991baef63c30382c2045d551b217140393a4264b18a5f1be198d325eee9f57e02dda38a7ad9f99771c5b78f82c673a88b04df122b9d91852db09efd WHIRLPOOL 8a9666142a1978e72b9eeb791de5c2033d0d29cd2db846f2583c41876d6a5c864c295316bb3d1c2858ccda0f4ca5081108ed9c07176eb8146c8c772fa77c8a60
+DIST networkx-1.11.tar.gz 1315737 SHA256 0d0e70e10dfb47601cbb3425a00e03e2a2e97477be6f80638fef91d54dd1e4b8 SHA512 622c93330bb5ba93a2be087f7f19963a1bb9a50dc72b6500ea8321c36aa9da19af379c5cd4bbee8bba3cb6e68a28f11ee24bbe333047f5c7d0ce0b755fd57253 WHIRLPOOL 64f68a750efef2f356525f4f2e1d8046327b223a4a55b3388fef1f7b68dac3796fbd05e7d997052ab644213ccea25a0584a2f4bbd660bc32b4c9aff9a92926c6
 DIST networkx-1.9.1.tar.gz 1035784 SHA256 6380eb38d0b5770d7e50813c8a48ff7c373b2187b4220339c1adce803df01c59 SHA512 8c18bd07530b26731da4db40dc9d82c81b78b086a2b15a45daa65ab55ec92a4ba836f911add062f698c3f319e5e85b5a26a6a52f760f5cf32e3d2a73c46cd93d WHIRLPOOL 01db9c8560140a52a890851871249c9d509883f7aa877487c16cdcc42973ae74b9c1815371d99247f72766e1f26e0a1afc0965af65583c4a9b59b75c2369fe2a
diff --git a/dev-python/networkx/networkx-1.11.ebuild b/dev-python/networkx/networkx-1.11.ebuild
new file mode 100644
index 000000000000..4508dcd7d846
--- /dev/null
+++ b/dev-python/networkx/networkx-1.11.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="http://networkx.github.io/ https://github.com/networkx/networkx"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+COMMON_DEPEND="
+	dev-python/matplotlib[${PYTHON_USEDEP}]
+		sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	doc? (
+		dev-python/sphinx[${PYTHON_USEDEP}]
+		dev-python/matplotlib[${PYTHON_USEDEP}]
+		$(python_gen_cond_dep 'dev-python/numpydoc[${PYTHON_USEDEP}]' python2_7)
+		$(python_gen_cond_dep 'dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]' python2_7 python{3_3,3_4})
+	)
+	test? (
+		${COMMON_DEPEND}
+		dev-python/nose[${PYTHON_USEDEP}]
+		$(python_gen_cond_dep 'media-gfx/pydot[${PYTHON_USEDEP}]' python2_7)
+	)"
+RDEPEND="
+	>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
+	examples? (
+		${COMMON_DEPEND}
+		dev-python/pygraphviz[${PYTHON_USEDEP}]
+		dev-python/pyparsing[${PYTHON_USEDEP}]
+		dev-python/pyyaml[${PYTHON_USEDEP}]
+	)"
+
+python_prepare_all() {
+	# Avoid d'loading of file objects.inv from 2 sites of python docs
+	sed -e "s/'sphinx.ext.intersphinx', //" -i doc/source/conf.py || die
+	distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+	# https://github.com/networkx/networkx/issues/1263
+	if use doc; then
+		sed \
+			-e "s:^\t\./:\t${PYTHON} :g" \
+			-i doc/Makefile || die
+		emake -C doc html
+	fi
+}
+
+python_test() {
+	nosetests -vv || die
+}
+
+python_install_all() {
+	# Oh my.
+	rm -r "${ED}"usr/share/doc/${P} || die
+
+	use doc && local HTML_DOCS=( doc/build/html/. )
+	use examples && local EXAMPLES=( examples/. )
+
+	distutils-r1_python_install_all
+}
-- 
cgit v1.2.3-65-gdbad