From b880e0047dcb62217bd81a160b8b68bd567a1fb1 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Sun, 23 Jun 2024 04:47:57 +0200
Subject: dev-python/nbxmpp: Bump to 5.0.1
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/nbxmpp/Manifest            |  1 +
 dev-python/nbxmpp/nbxmpp-5.0.1.ebuild | 35 +++++++++++++++++++++++++++++++++++
 2 files changed, 36 insertions(+)
 create mode 100644 dev-python/nbxmpp/nbxmpp-5.0.1.ebuild

(limited to 'dev-python/nbxmpp')

diff --git a/dev-python/nbxmpp/Manifest b/dev-python/nbxmpp/Manifest
index 79fb592b6398..23b509216d1f 100644
--- a/dev-python/nbxmpp/Manifest
+++ b/dev-python/nbxmpp/Manifest
@@ -1,2 +1,3 @@
 DIST python-nbxmpp-4.5.4.tar.bz2 138170 BLAKE2B 00a4919032dd29828dc735695afe9c0814a8fe2ec765a534257768896d9f27bc3a395275d546ad717bdd16c97161e8f0a8acaf43cdb7bd9404e40bc72f2c3da5 SHA512 fcaedae519d8cd2d52cc65721ab1e743569ba1cf7c29f2db41ed5671ba0f2c5b47f1f6d9521e1614e89e21512a4575c6788316cdb86936f0c4886d54c3831bb3
 DIST python-nbxmpp-5.0.0.tar.bz2 142680 BLAKE2B 9e54ad931ad5145c743f07e888eca519707b9179ece95d740c2209068cc02ee56b8af41bf18cf690ddb703485fab5f532b5bcf33eb74f022b0701c9421e3cd96 SHA512 0797e20dbdfaebbeb0a274786cb615cd0e57b26ec876ce94e5d66beb077510f8b38a97e0d0b151e2e069b10d1fe10b755d6531a4c676d7292675335314e4c214
+DIST python-nbxmpp-5.0.1.tar.bz2 142702 BLAKE2B 5459da538e3c05959c382e70fe8348b566333f4f68e76775b7bc8760f294ecc3bdb999124d1124bd5d7874af209f699eb4ffa1a15ce61ad70f98f235c70e98dd SHA512 eb20df090ec61013e6f26288798aeb2f2d61eab493cb4a52d5097a85d6dab8c45f033f2064583af5bf3ed920be33107419a958b65df2cf13fcd8ea6ae3297adf
diff --git a/dev-python/nbxmpp/nbxmpp-5.0.1.ebuild b/dev-python/nbxmpp/nbxmpp-5.0.1.ebuild
new file mode 100644
index 000000000000..0299ed984918
--- /dev/null
+++ b/dev-python/nbxmpp/nbxmpp-5.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+	https://dev.gajim.org/gajim/python-nbxmpp/
+	https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+	https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+	dev-libs/gobject-introspection
+	net-libs/libsoup:3.0[introspection]
+	dev-python/idna[${PYTHON_USEDEP}]
+	dev-python/packaging[${PYTHON_USEDEP}]
+	>=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+	>=dev-python/pygobject-3.42[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
-- 
cgit v1.2.3-65-gdbad