From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch | 25 +++++++++++++++++++++++
 dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch | 25 +++++++++++++++++++++++
 2 files changed, 50 insertions(+)
 create mode 100644 dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
 create mode 100644 dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch

(limited to 'dev-libs/yaz/files')

diff --git a/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch b/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
new file mode 100644
index 000000000000..a0aedfe05105
--- /dev/null
+++ b/dev-libs/yaz/files/yaz-3.0.47-icu-automagic.patch
@@ -0,0 +1,25 @@
+--- yaz-3.0.47/configure.ac.orig	2009-07-08 04:58:43.000000000 -0700
++++ yaz-3.0.47/configure.ac	2009-07-31 01:46:21.764545198 -0700
+@@ -367,14 +367,14 @@
+ 
+ dnl
+ dnl 
+-AC_CHECK_ICU([3.4],[
+-	if test "$xml_enabled" = "true"; then
+-	    ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
+-	else
+-	    ICU_CPPFLAGS=""
+-	    AC_MSG_WARN([ICU support disabled because XML support is unavailable])
+-	fi
+-])
++dnl ------ ICU
++AC_ARG_ENABLE(icu, [  --enable-icu            enable ICU support],[enable_icu=$enableval],[enable_icu=no])
++if test "$enable_icu" = "yes"; then
++    AC_CHECK_ICU([3.4],[
++       ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
++       AC_MSG_ERROR([For ICU support please install libicu34-dev or similar])
++    ])
++fi
+ dnl
+ dnl ------ Memory debugging
+ AC_ARG_ENABLE([memdebug],[  --enable-memdebug       enable memory debugging],[enable_memdebug=$enableval],[enable_memdebug=none])
diff --git a/dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch b/dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch
new file mode 100644
index 000000000000..e6854448b513
--- /dev/null
+++ b/dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch
@@ -0,0 +1,25 @@
+diff -Nuar yaz-4.2.30.orig/configure.ac yaz-4.2.30/configure.ac
+--- yaz-4.2.30.orig/configure.ac	2012-03-23 10:20:20.000000000 +0000
++++ yaz-4.2.30/configure.ac	2012-04-22 20:56:41.118691087 +0000
+@@ -372,14 +372,13 @@
+ 
+ dnl
+ dnl 
+-AC_CHECK_ICU([3.4],[
+-	if test "$xml_enabled" = "true"; then
+-	    ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
+-	else
+-	    ICU_CPPFLAGS=""
+-	    AC_MSG_WARN([ICU support disabled because XML support is unavailable])
+-	fi
+-])
++AC_ARG_ENABLE(icu, [  --enable-icu            enable ICU support],[enable_icu=$enableval],[enable_icu=no])
++if test "$enable_icu" = "yes"; then
++    AC_CHECK_ICU([3.4],[
++       ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
++       AC_MSG_ERROR([For ICU support please install libicu34-dev or similar])
++    ])
++fi
+ dnl ------ versioning
+ dnl
+ WIN_FILEVERSION=`echo $PACKAGE_VERSION | $AWK 'BEGIN { FS = "."; } { m = $4; printf("%d,%d,%d,%d", $1, $2, $3 == "" ? "0" : $3, $4 == "" ? "1" : $4);}'`
-- 
cgit v1.2.3-65-gdbad