From 494c10b41e8bdfca60ec5ae57e970cf1ad183f04 Mon Sep 17 00:00:00 2001
From: Lars Wendler <polynomial-c@gentoo.org>
Date: Fri, 5 Feb 2021 17:00:11 +0100
Subject: dev-libs/libgnt: Bump to version 2.14.1

Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
---
 dev-libs/libgnt/Manifest             |  1 +
 dev-libs/libgnt/libgnt-2.14.1.ebuild | 40 ++++++++++++++++++++++++++++++++++++
 2 files changed, 41 insertions(+)
 create mode 100644 dev-libs/libgnt/libgnt-2.14.1.ebuild

(limited to 'dev-libs/libgnt')

diff --git a/dev-libs/libgnt/Manifest b/dev-libs/libgnt/Manifest
index 088bdd50ab90..be3473656cc6 100644
--- a/dev-libs/libgnt/Manifest
+++ b/dev-libs/libgnt/Manifest
@@ -1 +1,2 @@
 DIST libgnt-2.14.0.tar.xz 102444 BLAKE2B 303dc33e60571ba4b5b9cc8ce477807b9b2ed6b4d1ed14e40c43e146a6d3d156741597befdf3e6c0c6816e9d43955f57f9e1b61e3f1f2d2fc451bf53f7236022 SHA512 0d9c5550374696a0e6ede5246cda3c372d7055d21b9ffaf10be88d6a469bdf18c7dd1113ec612acf4889c0e5686ea87bb0e8348ca8985fd5ff8913afc5813b38
+DIST libgnt-2.14.1.tar.xz 106564 BLAKE2B 19eddef51b44fa82982c705415fee43bf7495bc4692a7371fea782bcc21acdb932f15e1e8de6af962a529eea59f54c0b116d96b87ed3616201e6370760fac5b8 SHA512 434fff31a0946dabeaadbabaf96b4a7cf7f2a7da6d7794b7cf8a75f3f959388d89b32ce5921a20d5d6532ac2fd851ec2f6c18cc7cbc5a0ae97a00ff1ee3f74c3
diff --git a/dev-libs/libgnt/libgnt-2.14.1.ebuild b/dev-libs/libgnt/libgnt-2.14.1.ebuild
new file mode 100644
index 000000000000..17681c49a78e
--- /dev/null
+++ b/dev-libs/libgnt/libgnt-2.14.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Pidgin's GLib Ncurses Toolkit"
+HOMEPAGE="https://keep.imfreedom.org/libgnt/libgnt"
+SRC_URI="mirror://sourceforge/pidgin/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+	!<net-im/pidgin-2.14.0
+	dev-libs/glib:2
+	dev-libs/libxml2
+	sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+	dev-util/glib-utils
+	virtual/pkgconfig
+	doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+	"${FILESDIR}/${PN}-2.14.0-optional_docs.patch"
+	"${FILESDIR}/${PN}-2.14.0-tinfo.patch"
+)
+
+src_configure() {
+	local emesonargs=(
+		$(meson_use doc)
+	)
+	meson_src_configure
+}
-- 
cgit v1.2.3-65-gdbad