From 564d68aa779719c613994f6b933cbb3f31e00d3a Mon Sep 17 00:00:00 2001
From: Fabian Groffen <grobian@gentoo.org>
Date: Sat, 26 Dec 2020 13:44:38 +0100
Subject: dev-lang/perl: fix flock on sparc-solaris

Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
---
 dev-lang/perl/perl-5.30.3-r1.ebuild | 6 +++++-
 dev-lang/perl/perl-5.30.3-r2.ebuild | 6 +++++-
 dev-lang/perl/perl-5.32.0-r1.ebuild | 6 +++++-
 dev-lang/perl/perl-5.32.0.ebuild    | 6 +++++-
 4 files changed, 20 insertions(+), 4 deletions(-)

(limited to 'dev-lang/perl')

diff --git a/dev-lang/perl/perl-5.30.3-r1.ebuild b/dev-lang/perl/perl-5.30.3-r1.ebuild
index b437e661e578..e75625597fc7 100644
--- a/dev-lang/perl/perl-5.30.3-r1.ebuild
+++ b/dev-lang/perl/perl-5.30.3-r1.ebuild
@@ -463,6 +463,10 @@ src_configure() {
 	[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
 		append-cflags -Dinline=__inline__
 
+	# flock on 32-bit sparc Solaris is broken, fall back to fcntl
+	[[ ${CHOST} == sparc-*-solaris* ]] && \
+		myconf -Ud_flock
+
 	# fix unaligned access misdetection
 	# https://rt.perl.org/Public/Bug/Display.html?id=133495
 	# https://rt.perl.org/Public/Bug/Display.html?id=133803
@@ -478,7 +482,7 @@ src_configure() {
 		# Set a hook to check for each detected library whether it actually works.
 		export libscheck="
 			( echo 'main(){}' > '${T}'/conftest.c &&
-			  $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+				$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
 			) || xxx=/dev/null"
 
 		# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.
diff --git a/dev-lang/perl/perl-5.30.3-r2.ebuild b/dev-lang/perl/perl-5.30.3-r2.ebuild
index 6e6c7bf0efc9..0ad5fc03413b 100644
--- a/dev-lang/perl/perl-5.30.3-r2.ebuild
+++ b/dev-lang/perl/perl-5.30.3-r2.ebuild
@@ -619,6 +619,10 @@ src_configure() {
 	[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
 		append-cflags -Dinline=__inline__
 
+	# flock on 32-bit sparc Solaris is broken, fall back to fcntl
+	[[ ${CHOST} == sparc-*-solaris* ]] && \
+		myconf -Ud_flock
+
 	# fix unaligned access misdetection
 	# https://rt.perl.org/Public/Bug/Display.html?id=133495
 	# https://rt.perl.org/Public/Bug/Display.html?id=133803
@@ -634,7 +638,7 @@ src_configure() {
 		# Set a hook to check for each detected library whether it actually works.
 		export libscheck="
 			( echo 'main(){}' > '${T}'/conftest.c &&
-			  $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+				$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
 			) || xxx=/dev/null"
 
 		# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.
diff --git a/dev-lang/perl/perl-5.32.0-r1.ebuild b/dev-lang/perl/perl-5.32.0-r1.ebuild
index 0c5fdc0e83d1..0791da1fc3b8 100644
--- a/dev-lang/perl/perl-5.32.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.32.0-r1.ebuild
@@ -622,6 +622,10 @@ src_configure() {
 	[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
 		append-cflags -Dinline=__inline__
 
+	# flock on 32-bit sparc Solaris is broken, fall back to fcntl
+	[[ ${CHOST} == sparc-*-solaris* ]] && \
+		myconf -Ud_flock
+
 	# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
 	# Prefix itself we don't do multilib either, so make sure perl can find
 	# something compatible.
@@ -629,7 +633,7 @@ src_configure() {
 		# Set a hook to check for each detected library whether it actually works.
 		export libscheck="
 			( echo 'main(){}' > '${T}'/conftest.c &&
-			  $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+				$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
 			) || xxx=/dev/null"
 
 		# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.
diff --git a/dev-lang/perl/perl-5.32.0.ebuild b/dev-lang/perl/perl-5.32.0.ebuild
index b375dbc322bb..86be1e04a1c1 100644
--- a/dev-lang/perl/perl-5.32.0.ebuild
+++ b/dev-lang/perl/perl-5.32.0.ebuild
@@ -464,6 +464,10 @@ src_configure() {
 	[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
 		append-cflags -Dinline=__inline__
 
+	# flock on 32-bit sparc Solaris is broken, fall back to fcntl
+	[[ ${CHOST} == sparc-*-solaris* ]] && \
+		myconf -Ud_flock
+
 	# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
 	# Prefix itself we don't do multilib either, so make sure perl can find
 	# something compatible.
@@ -471,7 +475,7 @@ src_configure() {
 		# Set a hook to check for each detected library whether it actually works.
 		export libscheck="
 			( echo 'main(){}' > '${T}'/conftest.c &&
-			  $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+				$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
 			) || xxx=/dev/null"
 
 		# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.
-- 
cgit v1.2.3-65-gdbad