From cdc0774a75c8eecd1d68d2b0b1687884b88b9331 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Fri, 8 Nov 2019 21:48:24 +0100
Subject: */*: Inline mirror://hackage and update URIs
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This change inlines mirror://hackage in all ebuilds, and updates URIs
to the modern form (old URIs redirect to that).

The change has been made using the following command:

find -name '*.ebuild' -exec sed -r -i \
  -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \
  -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \
  -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \
  -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \
  -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \
  {} +

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-haskell/bytedump/bytedump-1.0.ebuild | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'dev-haskell/bytedump')

diff --git a/dev-haskell/bytedump/bytedump-1.0.ebuild b/dev-haskell/bytedump/bytedump-1.0.ebuild
index 7d9aaaec020d..bd407cafcc15 100644
--- a/dev-haskell/bytedump/bytedump-1.0.ebuild
+++ b/dev-haskell/bytedump/bytedump-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,7 +10,7 @@ inherit haskell-cabal
 
 DESCRIPTION="Flexible byte dump helpers for human readers"
 HOMEPAGE="https://github.com/vincenthz/hs-bytedump"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0/${PV}"
-- 
cgit v1.2.3-65-gdbad