From 2a02ec78aaf088c9d39df2d562498ec55fe87cdd Mon Sep 17 00:00:00 2001
From: Eray Aslan <eras@gentoo.org>
Date: Thu, 22 Dec 2016 16:59:40 +0300
Subject: app-crypt/heimdal: version bump to 7.1.0

Package-Manager: Portage-2.3.3, Repoman-2.3.1
---
 app-crypt/heimdal/Manifest             |   1 +
 app-crypt/heimdal/heimdal-7.1.0.ebuild | 174 +++++++++++++++++++++++++++++++++
 2 files changed, 175 insertions(+)
 create mode 100644 app-crypt/heimdal/heimdal-7.1.0.ebuild

(limited to 'app-crypt/heimdal')

diff --git a/app-crypt/heimdal/Manifest b/app-crypt/heimdal/Manifest
index 20cd2412e400..5862fdd0bb7e 100644
--- a/app-crypt/heimdal/Manifest
+++ b/app-crypt/heimdal/Manifest
@@ -1,2 +1,3 @@
 DIST heimdal-1.5.3.tar.gz 6798305 SHA256 aac27bedb33c341b6aed202af07ccc816146a893148721f8123abbbf93bbfea5 SHA512 5c7890f60d6fe6b5034fca204eb7cdb33fdc397fe09b169212b6267310b83bb0b3b06a4c2888841be34c92cbd701bd95734b4019c33c147459c4a449861c4431 WHIRLPOOL 8202b1bdf76e84b4a0fea1aa89935dfb3fbcceca38c84ffb3e3e8454691398c9a7cecfad40c6661426be5e82f4e3f43b6d6494cf287900ff958e06603b602e19
 DIST heimdal-7.0.1.tar.gz 8030155 SHA256 85971537cd439082437234172ec2da11f6601730233b204724d9d8c0a3b42af7 SHA512 f711f8d29d843286a2a513587c17eb8dabae5e3068a0181f33e4133e3f756d01d534add4e33e82e73d27628a13d7625dc87e5bea5b4068d205d13da926380508 WHIRLPOOL e3aed7536c104288898d1506928ff263ba00f9c33110b2af7243a2fc632217c0da672050d8fb20e1947cf87c371efda8b8da0a74d1f73f3085621472d5a024df
+DIST heimdal-7.1.0.tar.gz 9925587 SHA256 cee58ab3a4ce79f243a3e73f465dac19fe2b93ef1c5ff244d6f1d689fedbde2d SHA512 5afc9d183ff0db6e82e83d47955cc77e775bc60569e2905f9106c31b8a33e8d67fbc042dd4836ebae094db38bf70ba858c224189fed8d55f277738ee6e76352e WHIRLPOOL cd6507c5f6a800e645a146d94fac41d1fbf4c3283c5c4ab4a40bd2229efa4f1a16be71aa74fc5d8f41023bdff8ff141419ce0b99f5cb7aaf09f22824db1d2df8
diff --git a/app-crypt/heimdal/heimdal-7.1.0.ebuild b/app-crypt/heimdal/heimdal-7.1.0.ebuild
new file mode 100644
index 000000000000..7a95f7f28506
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-7.1.0.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+VIRTUALX_REQUIRED="manual"
+
+inherit autotools db-use eutils multilib multilib-minimal python-any-r1 virtualx flag-o-matic
+
+MY_P="${P}"
+DESCRIPTION="Kerberos 5 implementation from KTH"
+HOMEPAGE="http://www.h5l.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="afs +berkdb caps hdb-ldap ipv6 otp +pkinit selinux ssl static-libs test X"
+
+CDEPEND="ssl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+	berkdb? ( >=sys-libs/db-4.8.30-r1:*[${MULTILIB_USEDEP}] )
+	!berkdb? ( >=sys-libs/gdbm-1.10-r1[${MULTILIB_USEDEP}] )
+	caps? ( sys-libs/libcap-ng )
+	>=dev-db/sqlite-3.8.2[${MULTILIB_USEDEP}]
+	>=sys-libs/e2fsprogs-libs-1.42.9[${MULTILIB_USEDEP}]
+	sys-libs/ncurses:0=
+	>=sys-libs/readline-6.2_p5-r1[${MULTILIB_USEDEP}]
+	afs? ( net-fs/openafs )
+	hdb-ldap? ( >=net-nds/openldap-2.3.0 )
+	X? ( x11-libs/libX11
+		x11-libs/libXau
+		x11-libs/libXt )
+	abi_x86_32? (
+		!<=app-emulation/emul-linux-x86-baselibs-20140508-r1
+		!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+	)
+	!!app-crypt/mit-krb5
+	!!app-crypt/mit-krb5-appl"
+
+DEPEND="${CDEPEND}
+	${PYTHON_DEPS}
+	>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+	>=sys-devel/autoconf-2.62
+	test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+
+RDEPEND="${CDEPEND}
+	selinux? ( sec-policy/selinux-kerberos )"
+
+MULTILIB_WRAPPED_HEADERS=(
+	/usr/include/krb5-types.h
+	/usr/include/cms_asn1.h
+	/usr/include/digest_asn1.h
+	/usr/include/hdb_asn1.h
+	/usr/include/krb5_asn1.h
+	/usr/include/pkcs12_asn1.h
+	/usr/include/pkinit_asn1.h
+	/usr/include/rfc2459_asn1.h
+)
+
+MULTILIB_CHOST_TOOLS=(
+	/usr/bin/krb5-config
+)
+
+src_prepare() {
+	eapply "${FILESDIR}/heimdal_disable-check-iprop.patch"
+	eapply "${FILESDIR}/heimdal_tinfo.patch"
+	eautoreconf
+	eapply_user
+}
+
+src_configure() {
+	# QA
+	append-flags -fno-strict-aliasing
+
+	multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+	local myconf=()
+	if use berkdb; then
+		myconf+=(
+			--with-berkeley-db
+			--with-berkeley-db-include="$(db_includedir)"
+		)
+	else
+		myconf+=(
+			--without-berkeley-db
+		)
+	fi
+
+	ECONF_SOURCE=${S} \
+	econf \
+		--enable-kcm \
+		--disable-osfc2 \
+		--enable-shared \
+		--with-libintl=/usr \
+		--with-readline=/usr \
+		--with-sqlite3=/usr \
+		--libexecdir=/usr/sbin \
+		--enable-pthread-support \
+		$(use_enable afs afs-support) \
+		$(use_enable otp) \
+		$(use_enable pkinit kx509) \
+		$(use_enable pkinit pk-init) \
+		$(use_enable static-libs static) \
+		$(multilib_native_use_with caps capng) \
+		$(multilib_native_use_with hdb-ldap openldap /usr) \
+		$(use_with ipv6) \
+		$(use_with ssl openssl /usr) \
+		$(multilib_native_use_with X x) \
+		"${myconf[@]}"
+}
+
+multilib_src_compile() {
+	if multilib_is_native_abi; then
+		emake -j1
+	else
+		emake -C include -j1
+		emake -C base -j1
+		emake -C lib -j1
+		emake -C kdc -j1
+		emake -C tools -j1
+		emake -C tests/plugin -j1
+	fi
+}
+
+multilib_src_test() {
+	multilib_is_native_abi && emake -j1 check
+}
+
+multilib_src_install() {
+	if multilib_is_native_abi; then
+		INSTALL_CATPAGES="no" emake DESTDIR="${D}" install
+	else
+		emake -C include DESTDIR="${D}" install
+		emake -C base DESTDIR="${D}" install
+		emake -C lib DESTDIR="${D}" install
+		emake -C kdc DESTDIR="${D}" install
+		emake -C tools DESTDIR="${D}" install
+		emake -C tests/plugin DESTDIR="${D}" install
+	fi
+}
+
+multilib_src_install_all() {
+	dodoc ChangeLog* README NEWS TODO
+
+	# client rename
+	mv "${D}"/usr/share/man/man1/{,k}su.1
+	mv "${D}"/usr/bin/{,k}su
+
+	newinitd "${FILESDIR}"/heimdal-kdc.initd-r2 heimdal-kdc
+	newinitd "${FILESDIR}"/heimdal-kadmind.initd-r2 heimdal-kadmind
+	newinitd "${FILESDIR}"/heimdal-kpasswdd.initd-r2 heimdal-kpasswdd
+	newinitd "${FILESDIR}"/heimdal-kcm.initd-r1 heimdal-kcm
+
+	newconfd "${FILESDIR}"/heimdal-kdc.confd heimdal-kdc
+	newconfd "${FILESDIR}"/heimdal-kadmind.confd heimdal-kadmind
+	newconfd "${FILESDIR}"/heimdal-kpasswdd.confd heimdal-kpasswdd
+	newconfd "${FILESDIR}"/heimdal-kcm.confd heimdal-kcm
+
+	insinto /etc
+	newins "${S}"/krb5.conf krb5.conf.example
+
+	if use hdb-ldap; then
+		insinto /etc/openldap/schema
+		doins "${S}/lib/hdb/hdb.schema"
+	fi
+
+	prune_libtool_files
+
+	# default database dir
+	keepdir /var/heimdal
+}
-- 
cgit v1.2.3-65-gdbad