summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-composite-editor')
-rw-r--r--xfce-extra/xfce4-composite-editor/Manifest1
-rw-r--r--xfce-extra/xfce4-composite-editor/files/xfce4-composite-editor-0-validate.patch15
-rw-r--r--xfce-extra/xfce4-composite-editor/metadata.xml8
-rw-r--r--xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild36
4 files changed, 60 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-composite-editor/Manifest b/xfce-extra/xfce4-composite-editor/Manifest
new file mode 100644
index 000000000000..49b5d7ce0330
--- /dev/null
+++ b/xfce-extra/xfce4-composite-editor/Manifest
@@ -0,0 +1 @@
+DIST Xfce4-Composite-Editor-0.tar.gz 3027 SHA256 dc43c954c327a48e6cfd52e5ee8a7e36e7f4a3e24b3b10f3ef1643831d0791d9 SHA512 27f1b754d6eff167a117ac45bd2b459c3b7a789c929e8417564d7f5805a211f4fa2d2ee049bf28f0dc0c14ee84f4608c9669b269e9df78a17308ceaff9207516 WHIRLPOOL 0bdfd3be2f06b9986cd51c57067f780e5419f3df9e1f453193d8b3832bad32eb4b8d68be8b136d1c53ca17f6bf0648ca612b5ddcbefdfefb2ebf9497141de275
diff --git a/xfce-extra/xfce4-composite-editor/files/xfce4-composite-editor-0-validate.patch b/xfce-extra/xfce4-composite-editor/files/xfce4-composite-editor-0-validate.patch
new file mode 100644
index 000000000000..4088fe4bea20
--- /dev/null
+++ b/xfce-extra/xfce4-composite-editor/files/xfce4-composite-editor-0-validate.patch
@@ -0,0 +1,15 @@
+--- xfcecomped.desktop
++++ xfcecomped.desktop
+@@ -1,10 +1,7 @@
+ [Desktop Entry]
+-Version=1.0
+-Encoding=UTF-8
+-Name=Xfce4-Composite-Editor
+-Comment=Xfce4 Composite Options Editor
++Name=Xfce Composite Editor
+ Terminal=false
+ Type=Application
+-Categories=Gnome;GTK;;Settings;DesktopSettings;X-XFCE;
++Categories=XFCE;GTK;Settings;DesktopSettings;X-XFCE-SettingsDialog;X-XFCE-PersonalSettings;
+ Icon=xfce4-settings
+ Exec=xfce4-composite-editor
diff --git a/xfce-extra/xfce4-composite-editor/metadata.xml b/xfce-extra/xfce4-composite-editor/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-composite-editor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild b/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild
new file mode 100644
index 000000000000..1aff29ff14b5
--- /dev/null
+++ b/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+MY_PN=Xfce4-Composite-Editor
+
+DESCRIPTION="An graphical interface to modify composite settings"
+HOMEPAGE="http://keithhedger.hostingsiteforfree.com/pages/apps.html#xfcecomp"
+SRC_URI="http://keithhedger.hostingsiteforfree.com/zips/${MY_PN}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ >=x11-misc/gtkdialog-0.8"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-validate.patch )
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ dobin xfce4-composite-editor
+ domenu xfcecomped.desktop
+ dodoc README
+}