summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/zutty-0.16.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index 01f24e465028..43f754b4ea36 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1 +1,2 @@
DIST zutty-0.15.tar.gz 351752 BLAKE2B d7de40d490fb2674f939a20fde5f28d4438153a0a5397e801cbe255f3394f7d776107106882dab75fff51fa7d7de73e902679d9d0b4668f54e0417ae4cd95f9f SHA512 a0d482cc60ff3059c14f65fe0892ab81f793e1b98bb892136a7027399dac84360726187c9f47bdb40fcae0b9b361a929aba783c61fca7a57f844787c483c0884
+DIST zutty-0.16.tar.gz 361065 BLAKE2B 0f90057cea71453e07c59aba4d2e8b86d313e2bd9adbc22bd39c9a63e14e7879b23f17148e26f2e44dc010cd650eb35215e4cd382ef68c20df695d2d0b159b69 SHA512 170dd4592a8e87d419214bf1d91f5ce37ba7fe03d767a4fe1f554c164c277ad6eb272a6fbacd706b70ec6a4ab8fbbca3b09e093e8f0d7465f2066b8c0c4b21f3
diff --git a/x11-terms/zutty/zutty-0.16.ebuild b/x11-terms/zutty/zutty-0.16.ebuild
new file mode 100644
index 000000000000..cd366e974d1a
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_COMMIT=a578956
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://git.hq.sig7.se/zutty.git"
+SRC_URI="https://git.hq.sig7.se/zutty.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}-${MY_COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It is possible to run the tests using virtualx, but it seems to take
+# screenshots of the terminal window, and compares checksums that never
+# seem to match.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/freetype:2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove default CXX/LDFLAGS, bug #830405.
+ "${FILESDIR}"/${PN}-0.12-cxxflags.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )