summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmsmixer')
-rw-r--r--x11-plugins/wmsmixer/Manifest1
-rw-r--r--x11-plugins/wmsmixer/metadata.xml10
-rw-r--r--x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/wmsmixer/Manifest b/x11-plugins/wmsmixer/Manifest
new file mode 100644
index 000000000000..3d79f4df8755
--- /dev/null
+++ b/x11-plugins/wmsmixer/Manifest
@@ -0,0 +1 @@
+DIST wmsmixer-0.5.1.tar.gz 33350 RMD160 2f8ab0bf8571b9ea1e111f5e22c3df8ea017dec7 SHA1 32473bf99b7c0dfa4a2b7d0d850288354aebde58 SHA256 eee60a40ba92e4c2c9a038c6e51cd3bd62b24b38a096d091dc60dfd26f0c5daa
diff --git a/x11-plugins/wmsmixer/metadata.xml b/x11-plugins/wmsmixer/metadata.xml
new file mode 100644
index 000000000000..604b037085ff
--- /dev/null
+++ b/x11-plugins/wmsmixer/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+WMsmixer is a hack to wmmixer which makes some changes to the display
+and adds a few new features, most notably scrollwheel support. It also
+includes a numeric volume indicator.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
new file mode 100644
index 000000000000..f04e2ddeaee0
--- /dev/null
+++ b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+IUSE=""
+DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/63"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/268/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_compile() {
+ g++ ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
+ rm -f wmsmixer
+ g++ ${LDFLAGS} -o wmsmixer ${CFLAGS} -L/usr/X11R6/lib wmsmixer.o -lXpm -lXext -lX11
+}
+
+src_install() {
+ insinto /usr/bin
+ insopts -m0655
+ doins wmsmixer
+ dodoc README README.wmmixer
+}