summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmpop3')
-rw-r--r--x11-plugins/wmpop3/wmpop3-0.5.6a-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-plugins/wmpop3/wmpop3-0.5.6a-r1.ebuild b/x11-plugins/wmpop3/wmpop3-0.5.6a-r1.ebuild
index 66a7a0ebdd19..18b2d8dc76a1 100644
--- a/x11-plugins/wmpop3/wmpop3-0.5.6a-r1.ebuild
+++ b/x11-plugins/wmpop3/wmpop3-0.5.6a-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
+inherit eutils toolchain-funcs
DESCRIPTION="dockapp for checking pop3 accounts"
HOMEPAGE="http://www.cs.mun.ca/~scotth/"
@@ -20,7 +21,8 @@ RDEPEND="${DEPEND}"
PATCHES=( ${FILESDIR}/${P}-list.patch )
src_prepare() {
- sed -e "s:-O2:${CFLAGS}:" \
+ sed -e "s:cc :$(tc-getCC) :" \
+ -e "s:-O2:${CFLAGS}:" \
-e "s:-o wmpop3:${LDFLAGS} -o wmpop3:" \
-i ${PN}/Makefile || die