summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xearth')
-rw-r--r--x11-misc/xearth/Manifest1
-rw-r--r--x11-misc/xearth/files/xearth-1.1-include.patch10
-rw-r--r--x11-misc/xearth/metadata.xml6
-rw-r--r--x11-misc/xearth/xearth-1.1-r1.ebuild48
4 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/xearth/Manifest b/x11-misc/xearth/Manifest
new file mode 100644
index 000000000000..f7b02372b91f
--- /dev/null
+++ b/x11-misc/xearth/Manifest
@@ -0,0 +1 @@
+DIST xearth-1.1.tar.gz 157887 SHA256 bcb1407cc35b3f6dd3606b2c6072273b6a912cbd9ed1ae22fb2d26694541309c SHA512 ab1c146385a0e61f6208a0218cabc8a10902f52feb50f328a330cdbddc5d2eff2c3efdf6719b625bcc07171ed2fd6201230ad8a71cd77a451ad9c81383bfd46e WHIRLPOOL c5884f3d7bed815f3e9ebe96c078d8646602117744377d8b83065aa4218869a9acdfcd6373d65d6702a1f051a301a0f881cb7f2aae00b0e1db057b13759ab727
diff --git a/x11-misc/xearth/files/xearth-1.1-include.patch b/x11-misc/xearth/files/xearth-1.1-include.patch
new file mode 100644
index 000000000000..d3974b43f2e7
--- /dev/null
+++ b/x11-misc/xearth/files/xearth-1.1-include.patch
@@ -0,0 +1,10 @@
+--- a/gifout.c 1999-11-07 07:51:34.000000000 +0100
++++ b/gifout.c 2010-09-18 02:44:44.000000000 +0200
+@@ -44,6 +44,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "port.h"
+ #include "gifint.h"
+ #include "kljcpyrt.h"
diff --git a/x11-misc/xearth/metadata.xml b/x11-misc/xearth/metadata.xml
new file mode 100644
index 000000000000..0e92f1446c72
--- /dev/null
+++ b/x11-misc/xearth/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
+
diff --git a/x11-misc/xearth/xearth-1.1-r1.ebuild b/x11-misc/xearth/xearth-1.1-r1.ebuild
new file mode 100644
index 000000000000..e00b1c5b4ee6
--- /dev/null
+++ b/x11-misc/xearth/xearth-1.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://hewgill.com/xearth/original/"
+DESCRIPTION="Xearth sets the X root window to an image of the Earth"
+SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
+ ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="xearth"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ app-text/rman
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newman xearth.man xearth.1
+ dobin xearth
+ dodoc BUILT-IN GAMMA-TEST HISTORY README
+}