summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xac')
-rw-r--r--x11-misc/xac/Manifest1
-rw-r--r--x11-misc/xac/files/x86-biosfix.patch40
-rw-r--r--x11-misc/xac/metadata.xml7
-rw-r--r--x11-misc/xac/xac-0.6_pre4.ebuild57
4 files changed, 0 insertions, 105 deletions
diff --git a/x11-misc/xac/Manifest b/x11-misc/xac/Manifest
deleted file mode 100644
index 9bc7e55fcc32..000000000000
--- a/x11-misc/xac/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xac-0.6_pre4.tar.bz2 37409 SHA256 ff34e1e6e7027a22e712307e3832423b512af894e8ad9678e2f5d022a699a4d4 SHA512 461780097bee453a59eef0c12cdee380dd2de4c605db32222d02926e3febc2930f99c994356dbb359ae725554d1389e864944cf999b991d88336803b049d5026 WHIRLPOOL e5d5b538ff31a3fcc6a55b9a52cb9f113296ab8f9addc0eaec4a685e6f6f4965cd1a0b27b98c14ad8caf6b4e18b87cdea5ff686b4ed29e8dd33c6531ca3f3c09
diff --git a/x11-misc/xac/files/x86-biosfix.patch b/x11-misc/xac/files/x86-biosfix.patch
deleted file mode 100644
index 918cdf131d55..000000000000
--- a/x11-misc/xac/files/x86-biosfix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -u -B -r1.1 -r1.2
---- src/bioscall.h 25 Aug 2006 19:48:26 -0000 1.1
-+++ src/bioscall.h 30 Sep 2009 15:05:49 -0000 1.2
-@@ -1,6 +1,8 @@
- #ifndef bioscall_h
- #define bioscall_h
-
-+#include "int10defs.h"
-+
- /* Print some of the interesting parts of a vm86_regs structure. */
- void dump_regs(struct vm86_regs *regs);
-
-diff -u -B -r1.1 -r1.2
---- src/lrmi.h 25 Aug 2006 19:48:26 -0000 1.1
-+++ src/lrmi.h 30 Sep 2009 15:05:49 -0000 1.2
-@@ -26,6 +26,8 @@
- #ifndef LRMI_H
- #define LRMI_H
-
-+#include "int10defs.h"
-+
- #if defined(__i386__) && (defined(__linux__) || defined(__NetBSD__) \
- || defined(__FreeBSD__) || defined(__OpenBSD__))
-
-diff -Naur
---- src/int10defs.h
-+++ src/int10defs.h 30 Sep 2009 15:05:49 -0000
-@@ -0,0 +1,12 @@
-+/* Fix missing INT10 defines */
-+#ifndef IF_MASK
-+#define TF_MASK 0x00000100
-+#define IF_MASK 0x00000200
-+#define IOPL_MASK 0x00003000
-+#define NT_MASK 0x00004000
-+#define VM_MASK 0x00020000
-+#define AC_MASK 0x00040000
-+#define VIF_MASK 0x00080000 /* virtual interrupt flag */
-+#define VIP_MASK 0x00100000 /* virtual interrupt pending */
-+#define ID_MASK 0x00200000
-+#endif
diff --git a/x11-misc/xac/metadata.xml b/x11-misc/xac/metadata.xml
deleted file mode 100644
index 094389d518ae..000000000000
--- a/x11-misc/xac/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<longdescription lang="en">
-X.org autoconfiguration tool written in python.
-</longdescription>
-</pkgmetadata>
diff --git a/x11-misc/xac/xac-0.6_pre4.ebuild b/x11-misc/xac/xac-0.6_pre4.ebuild
deleted file mode 100644
index 4294380e0f15..000000000000
--- a/x11-misc/xac/xac-0.6_pre4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit toolchain-funcs eutils multilib
-
-DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
-HOMEPAGE="https://dev.gentoo.org/~josejx/xac.html"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc ppc64 ~x86"
-SLOT="0"
-IUSE="livecd"
-DEPEND=">=dev-lang/python-2.3
- sys-apps/pciutils"
-RDEPEND=">=dev-lang/python-2.3
- x11-base/xorg-server"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- ### Replace /usr/lib/xac with libdir version
- sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
-
- ### Fix the x86 bios call with newer glibc
- epatch "${FILESDIR}/x86-biosfix.patch"
-
- ### Make setup.py executable
- chmod +x "${S}/src/setup.py"
-}
-
-src_compile() {
- ### Compile the C bindings
- cd "${S}"/src
- ./setup.py build || die "Failed to build the C modules"
-}
-
-src_install() {
- local xac_base="/usr/$(get_libdir)/xac"
-
- dosbin "${S}"/xac
-
- ### Install the C mods
- cd "${S}"/src
- ./setup.py install --root "${D}" || die "Failed to install the C modules"
-
- dodir "${xac_base}"
- insinto ${xac_base}
- doins "${S}"/py/*
-
- ### Only install the init scripts if livecd is enabled
- if use livecd; then
- newinitd "${S}"/xac.init xac
- newconfd "${S}"/xac.conf xac
- fi
-}