summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/imake')
-rw-r--r--x11-misc/imake/Manifest3
-rw-r--r--x11-misc/imake/imake-1.0.5.ebuild24
-rw-r--r--x11-misc/imake/imake-1.0.6.ebuild24
-rw-r--r--x11-misc/imake/imake-1.0.7.ebuild24
-rw-r--r--x11-misc/imake/metadata.xml5
5 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/imake/Manifest b/x11-misc/imake/Manifest
new file mode 100644
index 000000000000..ec3d71e221c5
--- /dev/null
+++ b/x11-misc/imake/Manifest
@@ -0,0 +1,3 @@
+DIST imake-1.0.5.tar.bz2 148503 SHA256 99ce77ce73892d262522ee621032cef2fad2d30a36088b1305a156af4ee21cc1 SHA512 a3d114cdf093c60b6094b403d7fa9ab640ea227e602c6136ee15230ee0528f2f1cdc20056bf0598e411c7a19a3ac00c997ad421b8e393f205989776574b6e40e WHIRLPOOL 39cadd5c76946c7705ab2c4feda9da0f884ffacc03965b58dfdb3bcbbbb45c39420919bae58addbd5d3a4af000e1da1fc828937a02c5416fbda5cba0cfc65f3e
+DIST imake-1.0.6.tar.bz2 155571 SHA256 fa8983fdb0a72ba8482d1d2683967fb45c29edd7149b25f619f97ea5a599069d SHA512 5e0744903c8b044fac98859fee1d15fe1db4b8346a1b1fd0c8c8a683914c3a83a2d18316cadf1ab7ee455004b761c1fa7808bdf48bbfb9e7cbe6c7c143ad2f43 WHIRLPOOL 091e0f6e8708fccdede729f412b4ae777dbc329372d3dd99ea04181a1ddb41cd0e750ca1252cb72fba8377ffb535096e173d6bde97823060355f2d9765eda31f
+DIST imake-1.0.7.tar.bz2 156543 SHA256 690c2c4ac1fad2470a5ea73156cf930b8040dc821a0da4e322014a42c045f37e SHA512 b3527c8fead25c6e093e1fe4a39e60ff210212dcd323e206505b9e872a3f36d9db85f85cab5a6f0fa914fa5c558ef54b499b2b13ccd66739223e4e72ef805d08 WHIRLPOOL 4aa6d4819eb672e6470f7194f74ce997e7d3572f24c272ecab2211e5c141a9b8f9a71a2d137ac18e31628c921ecba0c964b90feff4233b00e095b5536d0d81e1
diff --git a/x11-misc/imake/imake-1.0.5.ebuild b/x11-misc/imake/imake-1.0.5.ebuild
new file mode 100644
index 000000000000..74db10af243c
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}
diff --git a/x11-misc/imake/imake-1.0.6.ebuild b/x11-misc/imake/imake-1.0.6.ebuild
new file mode 100644
index 000000000000..11067bf14c59
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}
diff --git a/x11-misc/imake/imake-1.0.7.ebuild b/x11-misc/imake/imake-1.0.7.ebuild
new file mode 100644
index 000000000000..dd8e63a00ba2
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}
diff --git a/x11-misc/imake/metadata.xml b/x11-misc/imake/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-misc/imake/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>