summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild
index 1035ce287cd4..43bc207ec36d 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild
@@ -507,7 +507,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then