summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn/gunicorn-19.8.1.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-19.8.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.8.1.ebuild b/www-servers/gunicorn/gunicorn-19.8.1.ebuild
deleted file mode 100644
index 199d85ec02d5..000000000000
--- a/www-servers/gunicorn/gunicorn-19.8.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="https://gunicorn.org https://pypi.org/project/gunicorn https://github.com/benoitc/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT PSF-2 doc? ( BSD )"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-DOCS="README.rst"
-
-python_prepare_all() {
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}