summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-46.4.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index ce8de90b7275..9d1a81eee526 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-46.0.tar.xz 4014980 BLAKE2B e9e72dc562b4ee63698e5b2c8f87945988cd5c585a10ee6782cd2a2fadbdb363292227869ed7f39f46305e007729594a37fc06a384a7a53e2061c2b3da181ce5 SHA512 55d1e89294e0f7cfae10b6aa28f43028bd34053e1d829168bf59b9cce8a8128a2ed7e9b94b8665e0f36e03adae845e0a26ff40c83abbc9962f06ac75e3c36a79
DIST epiphany-46.2.tar.xz 4021080 BLAKE2B f1ed20b1bd22ab047bff04276ac915996827d64b5edd7dfee6ae816522338f614b1329b051b84064cb1448590de7a432d521146a5a94915605f3841e6fc8c5c7 SHA512 fe564b2cb1c5f3528f974826d17608f133b8b99cc3dcfad1c641bf7aef792addbcb2418b7dba5a3c56305ee5fc2c955a5a12d1e64c50a60376f638cad3766ec9
+DIST epiphany-46.4.tar.xz 4013588 BLAKE2B f6f7044a0e20dd6fc696a1d667f37ecbf20d2ee2e21c42ccb26143565ac7629f436c6edffe5a022433de9b19db27007d57b3c135414af87d45fa3a551462822b SHA512 4bc3166152e1c3ee9bfd269000038d3c635824f2e3c7caa0b15deed69fd753658092479435244c1c89952fc4e1da14dcf6ccc910635949a0591b2c763c0adc19
diff --git a/www-client/epiphany/epiphany-46.4.ebuild b/www-client/epiphany/epiphany-46.4.ebuild
new file mode 100644
index 000000000000..033df849ad9a
--- /dev/null
+++ b/www-client/epiphany/epiphany-46.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.9.0:4=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.74.0:2
+ gnome-base/gsettings-desktop-schemas
+ media-libs/gstreamer:1.0
+ >=gui-libs/gtk-4.12.0:4
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=gui-libs/libadwaita-1.4.0:1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.43.4:6
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Test not ready to be run in sandboxed systems, also need
+ # mesa[zink]. Skip, as done by Debian.
+ # https://bugs.gentoo.org/928015
+ # https://bugs.gentoo.org/847862
+ # https://gitlab.gnome.org/GNOME/epiphany/-/issues/2209
+ # https://gitlab.gnome.org/GNOME/epiphany/-/issues/2271
+ "${FILESDIR}/${PN}-46.2-disable-web-view-test.patch"
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dgranite=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}