summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_auth_imap2')
-rw-r--r--www-apache/mod_auth_imap2/Manifest1
-rw-r--r--www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf36
-rw-r--r--www-apache/mod_auth_imap2/metadata.xml5
-rw-r--r--www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild28
4 files changed, 70 insertions, 0 deletions
diff --git a/www-apache/mod_auth_imap2/Manifest b/www-apache/mod_auth_imap2/Manifest
new file mode 100644
index 000000000000..c72f39db32c2
--- /dev/null
+++ b/www-apache/mod_auth_imap2/Manifest
@@ -0,0 +1 @@
+DIST mod_auth_imap2-2.2.0.tar.gz 12787 SHA256 9642a13932010b9587d7b2263f21bed29602253bac18cb6c8847385d13d3cce0
diff --git a/www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf b/www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf
new file mode 100644
index 000000000000..c82bf9e04518
--- /dev/null
+++ b/www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf
@@ -0,0 +1,36 @@
+<IfDefine AUTH_IMAP>
+LoadModule auth_imap_module modules/mod_auth_imap.so
+
+<Directory /var/www/localhost/htdocs>
+ # For Apache 2.2 the mod_auth_basic module is now set to
+ # be authoritative, and must be disabled if other modules
+ # are used for authentication.
+ #AuthBasicAuthoritative Off
+
+ # Turn on IMAP Authentication
+ #Auth_IMAP_Enabled on
+
+ # Give a name to the authentication domain, whatever you want:
+ #AuthName "something.com"
+
+ # Only basic authentication is supported for now:
+ #AuthType Basic
+
+ # If you feel like it, restrict the users or allow all "valid-user"
+ #Require user user1 user2
+
+ # Make IMAP Authentication authoritative for this .htaccess file:
+ #Auth_IMAP_Authoritative on
+
+ # Set the IMAP Server to which you want to connect (default=localhost):
+ #Auth_IMAP_Server imap.something.com
+
+ # Set the port on which the imap server is running (default=143):
+ #Auth_IMAP_Port 143
+
+ # Turn on some extra logging (login attempts, etc.) in Apache's Error Log
+ #Auth_IMAP_Log on
+</Directory>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_auth_imap2/metadata.xml b/www-apache/mod_auth_imap2/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_auth_imap2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild b/www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild
new file mode 100644
index 000000000000..aa36c707af83
--- /dev/null
+++ b/www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+MY_PN="${PN/imap2/imap}"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="An Apache2 module to provide authentication via an IMAP Mail server"
+HOMEPAGE="http://ben.brillat.net/projects/mod_auth_imap/"
+SRC_URI="http://ben.brillat.net/files/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APXS2_ARGS="-c ${MY_PN}.c"
+
+APACHE2_MOD_CONF="10_${MY_PN}"
+APACHE2_MOD_DEFINE="AUTH_IMAP"
+APACHE2_MOD_FILE=".libs/${MY_PN}.so"
+
+DOCFILES="CHANGELOG README examples/*"
+
+need_apache2