summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/audit-3.1.1.ebuild8
-rw-r--r--sys-process/audit/audit-3.1.2.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-process/audit/audit-3.1.1.ebuild b/sys-process/audit/audit-3.1.1.ebuild
index 347a7e71e862..97910e182b7e 100644
--- a/sys-process/audit/audit-3.1.1.ebuild
+++ b/sys-process/audit/audit-3.1.1.ebuild
@@ -34,7 +34,13 @@ DEPEND="
>=sys-kernel/linux-headers-2.6.34
test? ( dev-libs/check )
"
-BDEPEND="python? ( dev-lang/swig )"
+BDEPEND="python? (
+ dev-lang/swig
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' python3_12)
+ )
+"
CONFIG_CHECK="~AUDIT"
diff --git a/sys-process/audit/audit-3.1.2.ebuild b/sys-process/audit/audit-3.1.2.ebuild
index b4be6f0deebc..a01ceddb51ff 100644
--- a/sys-process/audit/audit-3.1.2.ebuild
+++ b/sys-process/audit/audit-3.1.2.ebuild
@@ -34,7 +34,13 @@ DEPEND="
>=sys-kernel/linux-headers-2.6.34
test? ( dev-libs/check )
"
-BDEPEND="python? ( dev-lang/swig )"
+BDEPEND="python? (
+ dev-lang/swig
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' python3_12)
+ )
+"
CONFIG_CHECK="~AUDIT"