summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/pkgcraft/pkgcraft-9999.ebuild')
-rw-r--r--sys-libs/pkgcraft/pkgcraft-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-libs/pkgcraft/pkgcraft-9999.ebuild b/sys-libs/pkgcraft/pkgcraft-9999.ebuild
index 493dc396d011..5ef300f81b23 100644
--- a/sys-libs/pkgcraft/pkgcraft-9999.ebuild
+++ b/sys-libs/pkgcraft/pkgcraft-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023-2024 Gentoo Authors
+# Copyright 2023-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ CRATES=" "
RUST_MIN_VER="1.77.1"
-inherit edo cargo flag-o-matic toolchain-funcs
+inherit edo cargo flag-o-matic multiprocessing toolchain-funcs
DESCRIPTION="C library for pkgcraft"
HOMEPAGE="https://pkgcraft.github.io/"
@@ -75,6 +75,8 @@ src_test() {
# pkgcraft-c.
cd "${WORKDIR}"/${P} || die
+ local -x NEXTEST_TEST_THREADS="$(makeopts_jobs)"
+
# Need nextest per README (separate processes required)
# Invocation from https://github.com/pkgcraft/pkgcraft/blob/main/.github/workflows/ci.yml#L56
edo cargo nextest run $(usev !debug '--release') --color always --all-features --tests