summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/Manifest3
-rw-r--r--sys-kernel/raspberrypi-sources/metadata.xml11
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.1_pre-r20130719.ebuild25
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.9999.ebuild28
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild28
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.14.9999.ebuild28
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.18.9999.ebuild28
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild28
8 files changed, 179 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/Manifest b/sys-kernel/raspberrypi-sources/Manifest
new file mode 100644
index 000000000000..4ecd8c3b26ad
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/Manifest
@@ -0,0 +1,3 @@
+DIST linux-3.10.tar.xz 73175088 SHA256 df27fa92d27a9c410bfe6c4a89f141638500d7eadcca5cce578954efc2ad3544 SHA512 5fb109fcbd59bf3dffc911b853894f0a84afa75151368f783a1252c5ff60c7a1504de216c0012be446df983e2dea400ad8eeed3ce04f24dc61d0ef76c174dc35 WHIRLPOOL e7c0ccc2231e430b831218fc66f1940d095d2d5447d391329c6a7373d4a1d16708f64778b32e4847802ee2dae4fcf7cb67a1238fd4eb204fd0c4bce2d8134053
+DIST patch-3.10.1.xz 5716 SHA256 1ce8533d0142acf9bb4c2167f0317580735a3c335b7303acbbd8127d01fb73e3 SHA512 6441aacbd2a3d1f1c2925397610e7343b7ed4e6fe80d64c52a261d12bb5cb7c44bcdc6aaa8aa975eabd90d8558820dad943fa2023451aa05825979af2b026ece WHIRLPOOL 3ed54bc6ba5741a884ec098a397b251aa610aa466090a65650b233baadc8627b2898f18719e2c91a087b0d5e3e3d20735eaf7d9c4e721bf7bd672ad4b9c1478c
+DIST raspberrypi-sources-3.10.1_pre-r20130719.patch.xz 1085996 SHA256 785a8227cca602d42b5c07f9d95d135fc5dc183dd418d04c6ffe3e58b64cb639 SHA512 a493a6f88844d7cd8371a6b4cf3509e0fb5ae5e0a07cb28f32d947cc42d469870f13506c0f62e3b83bca5d2ac48d17653daa1371dfd5b9bb2af9cb0831356048 WHIRLPOOL d5d49f3aa897635ad97997c55733ab09db5c8b70486e6e64f39c9e3b55ce4bec6060e5e81406644b8431acee0edf60dd5144f0d22de1bae7a6d9859f69e229cd
diff --git a/sys-kernel/raspberrypi-sources/metadata.xml b/sys-kernel/raspberrypi-sources/metadata.xml
new file mode 100644
index 000000000000..0f40772b7fee
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">raspberrypi/linux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.1_pre-r20130719.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.1_pre-r20130719.ebuild
new file mode 100644
index 000000000000..a864c3d8c77a
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.1_pre-r20130719.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+UNIPATCH_LIST="${DISTDIR}/${PF}.patch.xz"
+CKV="3.10.1"
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+# from github.com/rasperrypi/firmware/extra/git_hash
+# MY_COMMIT="b04d3b1874"
+# https://github.com/raspberrypi/linux/tarball/${MY_COMMIT} ->
+# raspberrypi-sources-${MY_COMMIT}.tar.gz
+SRC_URI="${KERNEL_URI}
+ http://dev.gentoo.org/~xmw/${PN}/${PF}.patch.xz"
+
+KEYWORDS="~arm"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.9999.ebuild
new file mode 100644
index 000000000000..1144e449e855
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.10.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
new file mode 100644
index 000000000000..1144e449e855
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.14.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.14.9999.ebuild
new file mode 100644
index 000000000000..ae80e7ac6b75
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.14.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.18.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.18.9999.ebuild
new file mode 100644
index 000000000000..9e7224829a8d
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.18.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild
new file mode 100644
index 000000000000..9e7224829a8d
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}