summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/bootcreator/bootcreator-1.2-r1.ebuild (renamed from sys-boot/bootcreator/bootcreator-1.2.ebuild)16
1 files changed, 7 insertions, 9 deletions
diff --git a/sys-boot/bootcreator/bootcreator-1.2.ebuild b/sys-boot/bootcreator/bootcreator-1.2-r1.ebuild
index 5f9a3fcc145e..3b5ce425244f 100644
--- a/sys-boot/bootcreator/bootcreator-1.2.ebuild
+++ b/sys-boot/bootcreator/bootcreator-1.2-r1.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Simple generator for Forth based BootMenu scripts for Pegasos machines"
HOMEPAGE="http://tbs-software.com/morgoth/projects.html"
SRC_URI="http://tbs-software.com/morgoth/files/bootcreator-src.tar.gz"
+S=${WORKDIR}
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="-* ppc"
-IUSE=""
-
-DEPEND=""
-
-S=${WORKDIR}
src_compile() {
- emake all
+ emake CC="$(tc-getCC)"
}
src_install() {