summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.6-r1.ebuild (renamed from sys-boot/gnu-efi/gnu-efi-3.0.6.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.6.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.6-r1.ebuild
index 838f2b4ecb0c..356ce6f38e93 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.6.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.6-r1.ebuild
@@ -19,7 +19,7 @@ SLOT="0"
# IA64 build is broken in setjmp code:
# https://sourceforge.net/p/gnu-efi/bugs/9/
KEYWORDS="-* ~amd64 ~arm ~arm64 -ia64 ~x86"
-IUSE="abi_x86_32 abi_x86_64"
+IUSE="abi_x86_32 abi_x86_64 -custom-cflags"
DEPEND="sys-apps/pciutils"
RDEPEND=""
@@ -61,8 +61,15 @@ efimake() {
src_compile() {
tc-export BUILD_CC AR AS CC LD
- # https://bugs.gentoo.org/607992
- filter-mfpmath sse
+ if use custom-cflags; then
+ # https://bugs.gentoo.org/607992
+ filter-mfpmath sse
+
+ # https://bugs.gentoo.org/619628
+ append-flags $(test-flags-CC -mno-avx)
+ else
+ unset CFLAGS CPPFLAGS LDFLAGS
+ fi
if [[ ${CHOST} == x86_64* ]]; then
use abi_x86_32 && CHOST=i686 ABI=x86 efimake