summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/uam')
-rw-r--r--sys-apps/uam/Manifest3
-rw-r--r--sys-apps/uam/metadata.xml21
-rw-r--r--sys-apps/uam/uam-0.3.1.ebuild45
-rw-r--r--sys-apps/uam/uam-0.3.2.ebuild45
-rw-r--r--sys-apps/uam/uam-0.3.ebuild51
-rw-r--r--sys-apps/uam/uam-9999.ebuild57
6 files changed, 222 insertions, 0 deletions
diff --git a/sys-apps/uam/Manifest b/sys-apps/uam/Manifest
new file mode 100644
index 000000000000..8eceed5c018f
--- /dev/null
+++ b/sys-apps/uam/Manifest
@@ -0,0 +1,3 @@
+DIST uam-0.3.1.tar.bz2 59632 SHA256 3f3b43d1aa7d58908d417fa5d35424b91c247c90a2bbec58c5f20198dfac9a5d SHA512 bcd7a37701eb73bf3443d1fa98372fc0788cb3101619265c012d010f83e2cccc17fa8bc033704396707aa6de9caf0a80c9637dd7c7d1f86b01fd844967dac5a5 WHIRLPOOL 55d0fdd5638eaeff95789cb43bdcb86e7fa9d3190445ece0830e8d74cb95cb868a2e902dc3897ad62e46d42e29e7d229dafc8c5e2fa6ef7d693baeee680a7f2c
+DIST uam-0.3.2.tar.bz2 60508 SHA256 f2aa2f98b2b270802d1b5d76d369cbf7615ae458a3fbc9a4f8d1f21623bf2170 SHA512 4a4ee9286b3762227fc5a03a10998cb3b4a2f110cd648bb2ed45f400e31218a17d3929c83450e9190255bda1f22f4001a7f33842999b79c27aa12fc11f286273 WHIRLPOOL 9ca2af7f823191aed523f1a0c44c59d1bfa70755c63fad6fe793ca808fe0f0409ee61f435a6db0f938b00cf38cf9230be8d2c22a45805396d5a19fbfe4d58376
+DIST uam-0.3.tar.bz2 58143 SHA256 fd31989ea9837edf9f26d07cf954f65fbbc00b0c97184fc84670f365df6c270b SHA512 6b5ce8b37ea7b430a492c4411ac005d6555e49bbc4849ae03c5bb16e7dd89e8cac32349dfa0507f01cc6b22bdb111eda69471141da4952f8425f9390035c6085 WHIRLPOOL 47874c1184cf08c3cd53b6e9cd5c7d1ed7ed33466974e23c6fb14cd2612c605567a034902f2ebea1f9e49c56c962b6eebc8e34a3b8fa6f055539f487ff056496
diff --git a/sys-apps/uam/metadata.xml b/sys-apps/uam/metadata.xml
new file mode 100644
index 000000000000..9ac331c9a557
--- /dev/null
+++ b/sys-apps/uam/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <longdescription>
+ A set of udev rules and scripts to mount USB media automatically
+ as soon as they are inserted. Features flexible configuration,
+ including mountpoint naming rules, and hooks.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/uam/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/uam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/uam/uam-0.3.1.ebuild b/sys-apps/uam/uam-0.3.1.ebuild
new file mode 100644
index 000000000000..b9c413bd2649
--- /dev/null
+++ b/sys-apps/uam/uam-0.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils udev user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://bitbucket.org/mgorny/uam/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ udev_reload
+}
diff --git a/sys-apps/uam/uam-0.3.2.ebuild b/sys-apps/uam/uam-0.3.2.ebuild
new file mode 100644
index 000000000000..1efc74887912
--- /dev/null
+++ b/sys-apps/uam/uam-0.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils udev user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://bitbucket.org/mgorny/uam/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ udev_reload
+}
diff --git a/sys-apps/uam/uam-0.3.ebuild b/sys-apps/uam/uam-0.3.ebuild
new file mode 100644
index 000000000000..e435b5181420
--- /dev/null
+++ b/sys-apps/uam/uam-0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://bitbucket.org/mgorny/uam/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README )
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ if [[ -e "${EROOT}"/dev/.udev ]]; then
+ ebegin "Calling udev to reload its rules"
+ udevadm control --reload-rules
+ eend $?
+ fi
+}
diff --git a/sys-apps/uam/uam-9999.ebuild b/sys-apps/uam/uam-9999.ebuild
new file mode 100644
index 000000000000..caec43f14f3a
--- /dev/null
+++ b/sys-apps/uam/uam-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils udev user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://bitbucket.org/mgorny/uam/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ udev_reload
+}