summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.11.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index a93c1d399ce2..d66bde349b58 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1 +1,2 @@
DIST pkgcore-0.12.10.tar.gz 625285 BLAKE2B e6d8aeec37e9f5379cc12ca9ff502bbfd8ab355087be63160b9a03feddb5c792cc0ef01d338926e3217ee01859fca5a84aa710db8e224dde8e2befc59e3fafad SHA512 8b5159a06e8291be1663de077ac089b0cfc0da1334111ee66cb6c3b627bb29ecbc7fa6b4727fef1d4c9ac93889a7de787114d07071157a1fc1ed0b5143ebe12f
+DIST pkgcore-0.12.11.tar.gz 625613 BLAKE2B f9bb17286cf30714d9f6f47ae6286031e418fd5f420e8921e1f1ed546cb1f293772e8d6e11ea2f4af8046d82fd166abb7c27f640f7f105c13a73d9ce19ccc52b SHA512 b98804603a9d14562efd56d01fa0b17ee1753d25b8c108d0d12eb47b103787f5fa7170f9924b473996817f31c31c40b5920db597974438cdc43215f5f83e43db
diff --git a/sys-apps/pkgcore/pkgcore-0.12.11.ebuild b/sys-apps/pkgcore/pkgcore-0.12.11.ebuild
new file mode 100644
index 000000000000..8ee26f5ac2e5
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.10[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
+ # https://bugs.gentoo.org/840266
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}