summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/guix')
-rw-r--r--sys-apps/guix/Manifest2
-rw-r--r--sys-apps/guix/guix-0.13.0-r1.ebuild138
-rw-r--r--sys-apps/guix/guix-0.14.0.ebuild150
3 files changed, 0 insertions, 290 deletions
diff --git a/sys-apps/guix/Manifest b/sys-apps/guix/Manifest
index 402815554d2c..88c1ca8fc612 100644
--- a/sys-apps/guix/Manifest
+++ b/sys-apps/guix/Manifest
@@ -1,5 +1,3 @@
-DIST guix-0.13.0.tar.gz 18490387 BLAKE2B e146f7a414f91076eafebe122c0abd772c1c2a562da015e952f978e97528c099905c1e7157e659633e644cbbd7066feac021550d52cb76d5999ff464fb685f2f SHA512 39d4e627f69850da650448b72008c1b73cbda0286d6b805bb1ea14d72eb49c5f6bdf30755b791a8b9cbb94e91ce8c1f360963250587591ce1a47db457c901daf
-DIST guix-0.14.0.tar.gz 19852695 BLAKE2B 257050ebebc35e7d6c82a30c3bb974da3d3eae9ca7c95dd8d98da6c60a68585330e5665b5343738188a058d84217d3c85731492e16afbd80c23771d40725b31c SHA512 635f6131c3ffa1ea5d18500fabc1d9d86d604a5cd3c8134d0f99dc44e171eef5d15f7ffa008c0e0726cf93fd0886afff0e9a5949014545d6919f8e8dba80eb69
DIST guix-0.15.0.tar.gz 22704560 BLAKE2B 6abd50c0436abedaa3a20ba9649ccf8af0efeeac8d975171befb4e9a231be99bfcebed34f08d66b4ddaedfd64a9916f176e96bf810dba3bbc13cc6856828b5be SHA512 5e85ed03cde979d625df11d02d4f2ac7128bd944d11a763754e10a8e980f1eaeb721053fa12547bbc4289b33b3c7818bf992c7bfe79233f3a9555c96b8d52d7f
DIST guix-0.16.0.tar.gz 24365691 BLAKE2B 7581f21fc9ccd4813b5e35b6a56980ffcd1ef9b02d5091679c33aaa91edf80acdc2bb9bd1a73acdde71b74d88e990ebbd824267756d9e7b27f94061cfd5a1429 SHA512 fdfa431547a283947147fde67e0dab27361a34caf7862c10659b17f74c63a07e6e834281be48a3dbe05cccd8ef46db5b8a19a6d42668ae2258d696058283724f
DIST guix-bootstrap-aarch64-linux-20170217-guile-2.0.14.tar.xz.bootstrap 2948976 BLAKE2B 3337e52c2db259af98a6ed0eb418a6cd388e11e09c277c460e14edb7065d0170fd544415ccb72db1b1b2559fe700ce313698aed11846271052460f9af51f499a SHA512 b3a5b457017357dedb71db98ef089ac90ca2b88ec5dbf0cec6c829dff7167c5478797a8d14850dd2d951713632c2859950be6c5eb029e6f6c224eecef97efd27
diff --git a/sys-apps/guix/guix-0.13.0-r1.ebuild b/sys-apps/guix/guix-0.13.0-r1.ebuild
deleted file mode 100644
index 1c93756b4d8d..000000000000
--- a/sys-apps/guix/guix-0.13.0-r1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools readme.gentoo-r1 user
-
-DESCRIPTION="GNU package manager (nix sibling)"
-HOMEPAGE="https://www.gnu.org/software/guix/"
-
-# taken from gnu/local.mk and build-aux/download.scm
-BOOT_GUILE=(
- "aarch64-linux 20170217 guile-2.0.14.tar.xz"
- "armhf-linux 20150101 guile-2.0.11.tar.xz"
- "i686-linux 20131110 guile-2.0.9.tar.xz"
- "mips64el-linux 20131110 guile-2.0.9.tar.xz"
- "x86_64-linux 20131110 guile-2.0.9.tar.xz"
-)
-
-binary_src_uris() {
- local system_date_guilep uri
- for system_date_guilep in "${BOOT_GUILE[@]}"; do
- # $1 $2 $3
- # "armhf-linux 20150101 guile-2.0.11.tar.xz"
- set -- ${system_date_guilep}
- uri="mirror://gnu-alpha/${PN}/bootstrap/$1/$2/$3"
- # ${uri} -> guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap
- echo "${uri} -> guix-bootstrap-$1-$2-$3.bootstrap"
- done
-}
-
-# copy bootstrap binaries from DISTDIR to ${S}
-copy_boot_guile_binaries() {
- local system_date_guilep
- for system_date_guilep in "${BOOT_GUILE[@]}"; do
- # $1 $2 $3
- # "armhf-linux 20150101 guile-2.0.11.tar.xz"
- set -- ${system_date_guilep}
- cp "${DISTDIR}"/guix-bootstrap-$1-$2-$3.bootstrap gnu/packages/bootstrap/$1/$3 || die
- done
-}
-
-SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz
- $(binary_src_uris)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # complains about size of config.log and refuses to start tests
-
-RDEPEND="
- dev-libs/libgcrypt:0=
- >=dev-scheme/guile-2:=[regex,networking,threads]
- dev-scheme/guile-json
- net-libs/gnutls[guile]
- sys-libs/zlib
- app-arch/bzip2
- dev-db/sqlite
-"
-
-DEPEND="${RDEPEND}
-"
-
-PATCHES=("${FILESDIR}"/${PN}-0.13.0-default-daemon.patch)
-
-QA_PREBUILT="usr/share/guile/site/2.0/gnu/packages/bootstrap/*"
-
-DISABLE_AUTOFORMATTING=yes
-DOC_CONTENTS="Quick start user guide on Gentoo:
-
-[as root] allow binary substitution to be downloaded (optional)
- # guix archive --authorize < /usr/share/guix/hydra.gnu.org.pub
-[as root] enable guix-daemon service:
- [systemd] # systemctl enable guix-daemon
- [openrc] # rc-update add guix-daemon
-[as a user] ln -sf /var/guix/profiles/per-user/\$USER/guix-profile \$HOME/.guix-profile
-[as a user] install guix packages:
- \$ guix package -i hello
-[as a user] configure environment:
- Somewhere in .bash_profile you might want to set
- export GUIX_LOCPATH=\$HOME/.guix-profile/lib/locale
-
-Next steps:
- guix package manager user manual: https://www.gnu.org/software/guix/manual/guix.html
-"
-
-pkg_setup() {
- enewgroup guixbuild
- for i in {1..10}; do
- # we list 'guixbuild' twice to
- # both assign a primary group for user
- # and add a user to /etc/group
- enewuser guixbuilder${i} -1 -1 /var/empty guixbuild,guixbuild
- done
-}
-
-src_prepare() {
- copy_boot_guile_binaries
-
- default
- # build system is very eager to run automake itself: bug #625166
- eautomake
-}
-
-src_configure() {
- # to be compatible with guix from /gnu/store
- econf \
- --localstatedir="${EPREFIX}"/var
-}
-
-src_compile() {
- # guile occasionally fails with 'bad address'
- emake -j1
-}
-
-src_install() {
- # TODO: emacs highlighter
- default
-
- readme.gentoo_create_doc
-
- keepdir /etc/guix
- # TODO: will need a tweak for prefix
- keepdir /gnu/store
- fowners root:guixbuild /gnu/store
- fperms 1775 /gnu/store
-
- keepdir /var/guix/profiles/per-user
- fperms 1777 /var/guix/profiles/per-user
-
- newinitd "${FILESDIR}"/guix-daemon.initd guix-daemon
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-apps/guix/guix-0.14.0.ebuild b/sys-apps/guix/guix-0.14.0.ebuild
deleted file mode 100644
index 31fd035cf39e..000000000000
--- a/sys-apps/guix/guix-0.14.0.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools readme.gentoo-r1 user
-
-DESCRIPTION="GNU package manager (nix sibling)"
-HOMEPAGE="https://www.gnu.org/software/guix/"
-
-# taken from gnu/local.mk and build-aux/download.scm
-BOOT_GUILE=(
- "aarch64-linux 20170217 guile-2.0.14.tar.xz"
- "armhf-linux 20150101 guile-2.0.11.tar.xz"
- "i686-linux 20131110 guile-2.0.9.tar.xz"
- "mips64el-linux 20131110 guile-2.0.9.tar.xz"
- "x86_64-linux 20131110 guile-2.0.9.tar.xz"
-)
-
-binary_src_uris() {
- local system_date_guilep uri
- for system_date_guilep in "${BOOT_GUILE[@]}"; do
- # $1 $2 $3
- # "armhf-linux 20150101 guile-2.0.11.tar.xz"
- set -- ${system_date_guilep}
- uri="mirror://gnu-alpha/${PN}/bootstrap/$1/$2/$3"
- # ${uri} -> guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap
- echo "${uri} -> guix-bootstrap-$1-$2-$3.bootstrap"
- done
-}
-
-# copy bootstrap binaries from DISTDIR to ${S}
-copy_boot_guile_binaries() {
- local system_date_guilep
- for system_date_guilep in "${BOOT_GUILE[@]}"; do
- # $1 $2 $3
- # "armhf-linux 20150101 guile-2.0.11.tar.xz"
- set -- ${system_date_guilep}
- cp "${DISTDIR}"/guix-bootstrap-$1-$2-$3.bootstrap gnu/packages/bootstrap/$1/$3 || die
- done
-}
-
-SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz
- $(binary_src_uris)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # complains about size of config.log and refuses to start tests
-
-RDEPEND="
- dev-libs/libgcrypt:0=
- >=dev-scheme/guile-2:=[regex,networking,threads]
- dev-scheme/bytestructures
- dev-scheme/guile-git
- dev-scheme/guile-json
- net-libs/gnutls[guile]
- sys-libs/zlib
- app-arch/bzip2
- dev-db/sqlite
-"
-
-DEPEND="${RDEPEND}
-"
-
-PATCHES=("${FILESDIR}"/${PN}-0.13.0-default-daemon.patch)
-
-QA_PREBUILT="usr/share/guile/site/*/gnu/packages/bootstrap/*"
-
-DISABLE_AUTOFORMATTING=yes
-DOC_CONTENTS="Quick start user guide on Gentoo:
-
-[as root] allow binary substitution to be downloaded (optional)
- # guix archive --authorize < /usr/share/guix/hydra.gnu.org.pub
-[as root] enable guix-daemon service:
- [systemd] # systemctl enable guix-daemon
- [openrc] # rc-update add guix-daemon
-[as a user] ln -sf /var/guix/profiles/per-user/\$USER/guix-profile \$HOME/.guix-profile
-[as a user] install guix packages:
- \$ guix package -i hello
-[as a user] configure environment:
- Somewhere in .bash_profile you might want to set
- export GUIX_LOCPATH=\$HOME/.guix-profile/lib/locale
-
-Next steps:
- guix package manager user manual: https://www.gnu.org/software/guix/manual/guix.html
-"
-
-pkg_setup() {
- enewgroup guixbuild
- for i in {1..10}; do
- # we list 'guixbuild' twice to
- # both assign a primary group for user
- # and add a user to /etc/group
- enewuser guixbuilder${i} -1 -1 /var/empty guixbuild,guixbuild
- done
-}
-
-src_prepare() {
- copy_boot_guile_binaries
-
- default
- # build system is very eager to run automake itself: bug #625166
- eautoreconf
-
- # guile is trying to avoid recompilation by checking if file
- # /usr/lib64/guile/2.2/site-ccache/guix/modules.go
- # is newer than
- # guix/modules.scm
- # In case it is instead of using 'guix/modules.scm' guile
- # loads system one (from potentially older version of guix).
- # To work it around we bump last modification timestamp of
- # '*.scm' files.
- find "${S}" -name "*.scm" -exec touch {} + || die
-}
-
-src_configure() {
- # to be compatible with guix from /gnu/store
- econf \
- --localstatedir="${EPREFIX}"/var
-}
-
-src_compile() {
- # guile occasionally fails with 'bad address'
- emake -j1
-}
-
-src_install() {
- # TODO: emacs highlighter
- default
-
- readme.gentoo_create_doc
-
- keepdir /etc/guix
- # TODO: will need a tweak for prefix
- keepdir /gnu/store
- fowners root:guixbuild /gnu/store
- fperms 1775 /gnu/store
-
- keepdir /var/guix/profiles/per-user
- fperms 1777 /var/guix/profiles/per-user
-
- newinitd "${FILESDIR}"/guix-daemon.initd guix-daemon
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}