summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dchroot/dchroot-0.12.1.ebuild')
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
new file mode 100644
index 000000000000..665be41e5172
--- /dev/null
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for managing chroots for non-root users"
+HOMEPAGE="http://packages.debian.org/unstable/admin/dchroot"
+SRC_URI="mirror://debian/pool/main/d/dchroot/dchroot_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/help2man"
+RDEPEND="!dev-util/schroot[dchroot]"
+
+src_prepare() {
+ sed -i \
+ -e '/^all:/s:$: docs:' \
+ -e '/^CFLAGS/s:-O2:@CFLAGS@:' \
+ -e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
+ Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README TODO
+}