summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/singular')
-rw-r--r--sci-mathematics/singular/Manifest1
-rw-r--r--sci-mathematics/singular/singular-4.2.1_p3-r1.ebuild120
2 files changed, 0 insertions, 121 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 42226a27aaaf..ad18fbcd80a4 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -1,4 +1,3 @@
DIST singular-4.2.0p1.tar.gz 14155171 BLAKE2B 444553f87d7ca8d6a62e4519c9857a6892757e92285df7c3b686913a9b51c9ae8d802c41382b0b2b6e37dc2dc496d4a10f262c98407470219cdce131e8baf127 SHA512 2ecd8940c9e8d70a93dbdb4df6da313c00151e5cb959f8eed5856e8df99089b5a03e514fbcdc70903c77df8b59fa7ef9f3b134f1de510b795fa6ea0341089bd8
-DIST singular-4.2.1p3.tar.gz 15042102 BLAKE2B 9958c1c432f8a3516387cfe7b258d2e22e8e9fdf3874de53a803b34e353088a3ce246a90b78db43f186717985b503d2355f524ee80784e63b186d53217fdeead SHA512 1e6533fcf966499e9ad145b640e7e5878eb9738bd65535aaa517c5e98dedb09bc99bf832359e9b6dca2fff615237f855bd861820e592a885341aa82e7a9a9168
DIST singular-4.3.1p1.tar.gz 15090370 BLAKE2B d4e40378b3892b98b1f78c3928c8a40484336ea25ea4dcd4b3a1e5f651281d2cdb06d92c9cc64427ce76e91c5bf4eaa1c3b643df174a24c188823ae808817ad9 SHA512 d27d8e042ea085e49aed6a0697056c36e78e62ea0b9d17751cdf4c556cf4f6efce3b34b411c77aef97c6d90675bea11c97651eb7009634cb8a9b630ec820a06e
DIST singular-4.3.1p2.tar.gz 15088650 BLAKE2B 17d73518653f6348297c955214aa8d30b3ce7cdf342f1bbb6fb49b746ddc563b1f46906df92f45abd601c834c77139f7aaccadf14bf706010017564d56948ca2 SHA512 ff2282b2fcd1a5b8809297036d524838403a2b66ae87ceb566ed6ff0571843d3c4aa0f7a4abbaab8541630f4e0130b6171ea0a7b8a5296b3b10f6c5cd5088828
diff --git a/sci-mathematics/singular/singular-4.2.1_p3-r1.ebuild b/sci-mathematics/singular/singular-4.2.1_p3-r1.ebuild
deleted file mode 100644
index 640dfeb3b453..000000000000
--- a/sci-mathematics/singular/singular-4.2.1_p3-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools elisp-common flag-o-matic
-
-MY_PN=Singular
-MY_PV=$(ver_rs 3 '')
-# Consistency is different...
-MY_DIR2=$(ver_cut 1-3 ${PV})
-MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
-
-DESCRIPTION="Computer algebra system for polynomial computations"
-HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
-SRC_URI="ftp://jim.mathematik.uni-kl.de/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_DIR2}"
-
-LICENSE="BSD GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~riscv ~x86 ~x86-linux"
-IUSE="emacs examples polymake +readline static-libs"
-
-RDEPEND="
- dev-lang/perl
- dev-libs/gmp:0
- dev-libs/ntl:=
- sci-libs/cddlib
- sci-mathematics/flint
- emacs? ( >=app-editors/emacs-23.1:* )
- polymake? ( sci-mathematics/polymake )
- readline? ( sys-libs/readline )
-"
-DEPEND="${RDEPEND}"
-
-SITEFILE=60${PN}-gentoo.el
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.2.1-htmldoc.patch"
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- # Needed to avoid segfaults in the test suite until
- #
- # https://github.com/Singular/Singular/issues/1105
- #
- # makes its way into a release.
- append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
-
- local myconf=(
- --disable-debug
- --disable-doc
- --disable-optimizationflags
- --disable-pyobject-module
- --disable-python
- --disable-python-module
- --disable-python_module
- --enable-factory
- --enable-gfanlib
- --enable-libfac
- --with-flint
- --with-gmp
- --with-libparse
- --with-ntl
- --without-python
- --without-pythonmodule
- $(use_enable emacs)
- $(use_enable polymake polymake-module)
- $(use_enable static-libs static)
- $(use_with readline)
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs; then
- pushd "${S}"/emacs
- elisp-compile *.el || die "elisp-compile failed"
- popd
- fi
-}
-
-src_install() {
- # Do not compress singular's info file (singular.hlp)
- # some consumer of that file do not know how to deal with compression
- docompress -x /usr/share/info
-
- default
-
- dosym Singular /usr/bin/"${PN}"
-
- # purge .la file
- find "${ED}" -name '*.la' -delete || die
-}
-
-src_test() {
- # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
- # an already installed version of singular may be used and cause segfault
- # See https://github.com/Singular/Sources/issues/980
- SINGULAR_PROCS_DIR="" emake check
-}
-
-pkg_postinst() {
- einfo "Additional functionality can be enabled by installing"
- einfo "sci-mathematics/4ti2"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}