summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/makecif/makecif-5.6.6.ebuild')
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-chemistry/makecif/makecif-5.6.6.ebuild b/sci-chemistry/makecif/makecif-5.6.6.ebuild
new file mode 100644
index 000000000000..3a5f70a8b259
--- /dev/null
+++ b/sci-chemistry/makecif/makecif-5.6.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="PDB --> CIF convertor"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/makecif.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+LICENSE="ccp4"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+DEPEND=""
+RDEPEND="
+ !>=sci-chemistry/refmac-5.6
+ sci-libs/monomer-db"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-makefile.patch
+}
+
+src_compile() {
+ cd src && emake clean
+ emake \
+ BLANC_FORT="$(tc-getFC) ${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc readme
+}