summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/openbsc/openbsc-9999.ebuild')
-rw-r--r--net-wireless/openbsc/openbsc-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-wireless/openbsc/openbsc-9999.ebuild b/net-wireless/openbsc/openbsc-9999.ebuild
new file mode 100644
index 000000000000..a8b11303a00a
--- /dev/null
+++ b/net-wireless/openbsc/openbsc-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools git-2 eutils
+
+DESCRIPTION="OpenBSC, OsmoSGSN, OsmoBSC and other programs"
+HOMEPAGE="http://openbsc.osmocom.org/trac/wiki/OpenBSC"
+EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+EGIT_BRANCH="jolly/testing"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+gprs"
+
+DEPEND="
+ gprs? ( net-wireless/openggsn )
+ net-libs/libosmocore
+ net-libs/libosmo-abis
+ dev-db/libdbi"
+RDEPEND="${DEPEND}
+ dev-db/libdbi-drivers[sqlite]
+ dev-db/sqlite:3"
+
+S="${WORKDIR}/${P}/${PN}"
+EGIT_SOURCEDIR="${WORKDIR}/${P}"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}