summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/rhapsody')
-rw-r--r--net-irc/rhapsody/Manifest1
-rw-r--r--net-irc/rhapsody/files/rhapsody-0.28b-uclibc.patch10
-rw-r--r--net-irc/rhapsody/metadata.xml8
-rw-r--r--net-irc/rhapsody/rhapsody-0.28b.ebuild37
4 files changed, 56 insertions, 0 deletions
diff --git a/net-irc/rhapsody/Manifest b/net-irc/rhapsody/Manifest
new file mode 100644
index 000000000000..c9fca0ebcc91
--- /dev/null
+++ b/net-irc/rhapsody/Manifest
@@ -0,0 +1 @@
+DIST rhapsody_0.28b.tgz 110062 SHA256 606d767f9bd4c810343b1ce94492f4aaf993552edee090ec881627b29294b4dd SHA512 1ff9f29d281421b7fe3dcdccbd8b2559572cc6e7167ff9e0f1a46dcff07486115de245055b3d72107f40f40a484d9aef94c7ed21b55a7bdf80094198d69dec6d WHIRLPOOL b8b26234f045b687e68b3fd923cd1281dffcbb5fe2b5b50176d2c08f647e34612fb530cf47fef47c08b79da0ce2ae7a57e4cb4f962dff0ddf5281e849d8d6858
diff --git a/net-irc/rhapsody/files/rhapsody-0.28b-uclibc.patch b/net-irc/rhapsody/files/rhapsody-0.28b-uclibc.patch
new file mode 100644
index 000000000000..28196177414f
--- /dev/null
+++ b/net-irc/rhapsody/files/rhapsody-0.28b-uclibc.patch
@@ -0,0 +1,10 @@
+--- rhapsody-0.28b/src/main.c.orig 2008-04-29 09:53:53 +0000
++++ rhapsody-0.28b/src/main.c 2008-04-29 09:55:13 +0000
+@@ -20,6 +20,7 @@
+ /* */
+ /*****************************************************************************/
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
diff --git a/net-irc/rhapsody/metadata.xml b/net-irc/rhapsody/metadata.xml
new file mode 100644
index 000000000000..832ac05e1ab0
--- /dev/null
+++ b/net-irc/rhapsody/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <upstream>
+ <remote-id type="sourceforge">rhapsody</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/rhapsody/rhapsody-0.28b.ebuild b/net-irc/rhapsody/rhapsody-0.28b.ebuild
new file mode 100644
index 000000000000..761097d4c72b
--- /dev/null
+++ b/net-irc/rhapsody/rhapsody-0.28b.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="IRC client intended to be displayed on a text console"
+HOMEPAGE="http://rhapsody.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-uclibc.patch
+}
+
+src_compile() {
+ ./configure -i /usr/share/rhapsody || die "configure failed"
+ emake CC="$(tc-getCC)" LOCALFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin rhapsody || die "dobin failed"
+
+ insinto /usr/share/rhapsody/help
+ doins help/*.hlp || die "doins failed"
+
+ dodoc docs/CHANGELOG || die "dodoc failed"
+}