summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/freeradius-client')
-rw-r--r--net-dialup/freeradius-client/Manifest1
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.6.ebuild33
-rw-r--r--net-dialup/freeradius-client/metadata.xml16
3 files changed, 50 insertions, 0 deletions
diff --git a/net-dialup/freeradius-client/Manifest b/net-dialup/freeradius-client/Manifest
new file mode 100644
index 000000000000..03485b8e64d5
--- /dev/null
+++ b/net-dialup/freeradius-client/Manifest
@@ -0,0 +1 @@
+DIST freeradius-client-1.1.6.tar.bz2 297916 SHA256 a3c9522ed6d9bc795794595a8f3eebada868ea11a0c046637500faf257f9688f
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.6.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.6.ebuild
new file mode 100644
index 000000000000..4105214a8277
--- /dev/null
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="FreeRADIUS Client framework"
+HOMEPAGE="http://wiki.freeradius.org/Radiusclient"
+SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scp shadow"
+
+DEPEND="!net-dialup/radiusclient
+ !net-dialup/radiusclient-ng"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable scp) \
+ $(use_enable shadow) \
+ --with-secure-path || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc BUGS README* doc/ChangeLog doc/login.example doc/release-method.txt
+ newdoc doc/README README.login.example
+ dohtml doc/instop.html
+}
diff --git a/net-dialup/freeradius-client/metadata.xml b/net-dialup/freeradius-client/metadata.xml
new file mode 100644
index 000000000000..1c0b9d808f6e
--- /dev/null
+++ b/net-dialup/freeradius-client/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>FreeRADIUS Client is a framework and library for writing
+RADIUS Clients which additionally includes radlogin, a flexible RADIUS
+aware login replacement, a command line program to send RADIUS accounting
+records, a utility allowing to send RADIUS AAA requests from command
+line or from shell scripts and a utility to query the status of a (Merit)
+RADIUS server.</longdescription>
+<use>
+ <flag name='scp'>Add service type hints derived from username
+ prefix</flag>
+ <flag name='shadow'>Enable shadow password support</flag>
+</use>
+</pkgmetadata>