summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.13.ebuild2
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.14.ebuild2
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.5.ebuild2
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.6.ebuild2
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild2
5 files changed, 10 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.6.13.ebuild b/net-analyzer/wireshark/wireshark-3.6.13.ebuild
index 0079012cf99c..5bcc3eef297d 100644
--- a/net-analyzer/wireshark/wireshark-3.6.13.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.13.ebuild
@@ -136,6 +136,8 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
+ ! use lto && filter-lto
+
python_setup
mycmakeargs+=(
diff --git a/net-analyzer/wireshark/wireshark-3.6.14.ebuild b/net-analyzer/wireshark/wireshark-3.6.14.ebuild
index 1aa6426c7849..883f96d5450c 100644
--- a/net-analyzer/wireshark/wireshark-3.6.14.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.14.ebuild
@@ -136,6 +136,8 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
+ ! use lto && filter-lto
+
python_setup
mycmakeargs+=(
diff --git a/net-analyzer/wireshark/wireshark-4.0.5.ebuild b/net-analyzer/wireshark/wireshark-4.0.5.ebuild
index 6039d7e9573b..cd157e078c5f 100644
--- a/net-analyzer/wireshark/wireshark-4.0.5.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.5.ebuild
@@ -170,6 +170,8 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
+ ! use lto && filter-lto
+
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
-DCMAKE_DISABLE_FIND_PACKAGE_{Asciidoctor,DOXYGEN}=$(usex !doc)
diff --git a/net-analyzer/wireshark/wireshark-4.0.6.ebuild b/net-analyzer/wireshark/wireshark-4.0.6.ebuild
index bda06a2c3b77..2a642376f5e0 100644
--- a/net-analyzer/wireshark/wireshark-4.0.6.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.6.ebuild
@@ -170,6 +170,8 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
+ ! use lto && filter-lto
+
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
-DCMAKE_DISABLE_FIND_PACKAGE_{Asciidoctor,DOXYGEN}=$(usex !doc)
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 88ddb144b999..e6c490a67458 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -171,6 +171,8 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
+ ! use lto && filter-lto
+
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
-DCMAKE_DISABLE_FIND_PACKAGE_{Asciidoctor,DOXYGEN}=$(usex !doc)