summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zmap/zmap-9999.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
index eaed24c6933d..04e4602032d2 100644
--- a/net-analyzer/zmap/zmap-9999.ebuild
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,13 +13,12 @@ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS=""
-IUSE="mongo redis"
+IUSE="redis"
RDEPEND="
dev-libs/gmp:0
net-libs/libpcap
dev-libs/json-c:=
- mongo? ( dev-db/mongodb )
redis? ( dev-libs/hiredis )"
DEPEND="${RDEPEND}
dev-util/gengetopt
@@ -30,10 +29,8 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DENABLE_DEVELOPMENT=OFF
- -DENABLE_HARDENING=OFF
-DWITH_WERROR=OFF
- -DWITH_mongo="$(usex mongo)"
- -DWITH_redis="$(usex redis)"
+ -DWITH_REDIS="$(usex redis)"
)
cmake-utils_src_configure
}