summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/alive/alive-2.0.5.ebuild')
-rw-r--r--net-analyzer/alive/alive-2.0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/alive/alive-2.0.5.ebuild b/net-analyzer/alive/alive-2.0.5.ebuild
new file mode 100644
index 000000000000..567f090930f3
--- /dev/null
+++ b/net-analyzer/alive/alive-2.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="A periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND="dev-scheme/guile"
+RDEPEND="${DEPEND}
+ dev-scheme/xdgdirs
+ net-misc/iputils"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-ping-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}