summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/files/gegl-0.2.0-underlinking.patch38
-rw-r--r--media-libs/gegl/gegl-0.2.0-r2.ebuild5
2 files changed, 42 insertions, 1 deletions
diff --git a/media-libs/gegl/files/gegl-0.2.0-underlinking.patch b/media-libs/gegl/files/gegl-0.2.0-underlinking.patch
new file mode 100644
index 000000000000..4468f387855a
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.2.0-underlinking.patch
@@ -0,0 +1,38 @@
+From db19965ad957edee3c2ef3e321c3904b436749da Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 9 Jan 2017 21:38:42 +0100
+Subject: [PATCH] Backport $(MATH_LIB) patch to GEGL 0.2
+
+Source:
+https://git.gnome.org/browse/gegl/patch/?id=c9bbc815378cb81ba8a48be35f615e7e2d74dffc
+---
+ bin/Makefile.am | 2 +-
+ examples/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/bin/Makefile.am b/bin/Makefile.am
+index c85ecbd..08a156b 100644
+--- a/bin/Makefile.am
++++ b/bin/Makefile.am
+@@ -23,7 +23,7 @@ AM_CFLAGS = \
+
+ AM_LDFLAGS = \
+ $(no_undefined) ../gegl/libgegl-$(GEGL_API_VERSION).la \
+- $(DEP_LIBS) $(BABL_LIBS) $(PNG_LIBS) $(LIBSPIRO)
++ $(DEP_LIBS) $(BABL_LIBS) $(PNG_LIBS) $(LIBSPIRO) $(MATH_LIB)
+
+ bin_PROGRAMS = gegl
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index c29a1dd..5c4ac3a 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -42,4 +42,4 @@ AM_CFLAGS = $(DEP_CFLAGS) $(GTK_CFLAGS) $(BABL_CFLAGS) $(PNG_CFLAGS)
+
+ AM_LDFLAGS = \
+ $(top_builddir)/gegl/libgegl-$(GEGL_API_VERSION).la \
+- $(DEP_LIBS) $(GTK_LIBS) $(BABL_LIBS) $(PNG_LIBS)
++ $(DEP_LIBS) $(GTK_LIBS) $(BABL_LIBS) $(PNG_LIBS) $(MATH_LIB)
+--
+2.11.0
+
diff --git a/media-libs/gegl/gegl-0.2.0-r2.ebuild b/media-libs/gegl/gegl-0.2.0-r2.ebuild
index fec143cd220e..2e8582abb163 100644
--- a/media-libs/gegl/gegl-0.2.0-r2.ebuild
+++ b/media-libs/gegl/gegl-0.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -72,6 +72,9 @@ src_prepare() {
fi
epatch "${FILESDIR}"/${P}-g_log_domain.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=605216
+ epatch "${FILESDIR}"/${P}-underlinking.patch
eautoreconf
# https://bugs.gentoo.org/show_bug.cgi?id=468248