summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/thunderbird/thunderbird-115.12.1.ebuild')
-rw-r--r--mail-client/thunderbird/thunderbird-115.12.1.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/mail-client/thunderbird/thunderbird-115.12.1.ebuild b/mail-client/thunderbird/thunderbird-115.12.1.ebuild
index 582b2c7d6c1d..a0a938341cd3 100644
--- a/mail-client/thunderbird/thunderbird-115.12.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-115.12.1.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-115esr-patches-09.tar.xz"
+FIREFOX_PATCHSET="firefox-115esr-patches-11.tar.xz"
-LLVM_MAX_SLOT=17
+LLVM_MAX_SLOT=18
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="ncurses,sqlite,ssl"
@@ -82,6 +82,15 @@ TB_ONLY_DEPEND="!<x11-plugins/enigmail-2.2
BDEPEND="${PYTHON_DEPS}
|| (
(
+ sys-devel/clang:18
+ sys-devel/llvm:18
+ clang? (
+ sys-devel/lld:18
+ virtual/rust:0/llvm-18
+ pgo? ( =sys-libs/compiler-rt-sanitizers-18*[profile] )
+ )
+ )
+ (
sys-devel/clang:17
sys-devel/llvm:17
clang? (
@@ -682,6 +691,10 @@ src_prepare() {
# Clear cargo checksums from crates we have patched
# moz_clear_vendor_checksums crate
moz_clear_vendor_checksums audio_thread_priority
+ moz_clear_vendor_checksums bindgen
+ moz_clear_vendor_checksums encoding_rs
+ moz_clear_vendor_checksums any_all_workaround
+ moz_clear_vendor_checksums packed_simd
# Create build dir
BUILD_DIR="${WORKDIR}/${PN}_build"