summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/cone/files')
-rw-r--r--mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch84
-rw-r--r--mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch11
-rw-r--r--mail-client/cone/files/cone-0.90-gnutls3.patch72
3 files changed, 167 insertions, 0 deletions
diff --git a/mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch b/mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch
new file mode 100644
index 000000000000..d6b4d09b5f23
--- /dev/null
+++ b/mail-client/cone/files/cone-0.84.20100819-aspell-automagic.patch
@@ -0,0 +1,84 @@
+--- cone-0.84.20100819/cone/configure.in.orig 2010-11-11 22:08:37.279191265 -0800
++++ cone-0.84.20100819/cone/configure.in 2010-11-11 23:26:22.685898387 -0800
+@@ -168,19 +168,9 @@
+ LIBS="$save_LIBS"
+ AC_MSG_RESULT($PSPELL)
+
+-ALLSPELLOBJ='spellcheckerNone.$(OBJEXT)'
+-if test "$ASPELL" = "yes"
+-then
+- ALLSPELLOBJ='spellcheckerAspell.$(OBJEXT)'" $ALLSPELLOBJ"
+-fi
+-
+-if test "$PSPELL" = "yes"
+-then
+- ALLSPELLOBJ='spellcheckerPspell.$(OBJEXT)'" $ALLSPELLOBJ"
+-fi
+-
+ AC_ARG_WITH(spellcheck, [ --with-spellcheck=pspell Use pspell for spell checking
+- --with-spellcheck=aspell Use aspell for spell checking], [
++ --with-spellcheck=aspell Use aspell for spell checking
++ --with-spellcheck=none Disable spell checking], [
+
+ case "$withval" in
+ pspell)
+@@ -196,6 +186,10 @@
+ AC_MSG_ERROR(aspell library not found)
+ fi
+ ;;
++none)
++ SPELL="no"
++ # Spellchecking is not enabled
++ ;;
+ *)
+ AC_MSG_ERROR(Invalid --with-spellcheck option)
+ ;;
+@@ -216,24 +210,34 @@
+ AC_MSG_RESULT(yes)
+ ], AC_MSG_RESULT(no))
+
+-if test "$ASPELL" = "yes"
++if test "$SPELL" = "no"
+ then
+- SPELL_OBJ='spellcheckerAspell.$(OBJEXT)'
+- AC_DEFINE_UNQUOTED(USE_ASPELL, 1, [ Use aspell library for spell checking ])
+- SPELL_LIB='-laspell'
++ ALLSPELLOBJ='spellcheckerNone.$(OBJEXT)'
++ SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
++ SPELL_LIB=''
++ AC_MSG_WARN(Disabling spell checking)
+ else
+- if test "$PSPELL" = "yes"
++ if test "$ASPELL" = "yes"
+ then
+- AC_DEFINE_UNQUOTED(USE_PSPELL, 1, [ Use aspell library for spell checking ])
+- SPELL_OBJ='spellcheckerPspell.$(OBJEXT)'
+- SPELL_LIB='-lpspell'
++ ALLSPELLOBJ='spellcheckerAspell.$(OBJEXT)'" $ALLSPELLOBJ"
++ SPELL_OBJ='spellcheckerAspell.$(OBJEXT)'
++ AC_DEFINE_UNQUOTED(USE_ASPELL, 1, [ Use aspell library for spell checking ])
++ SPELL_LIB='-laspell'
+ else
+- AC_MSG_WARN(---------------------------------------------------------------)
+- AC_MSG_WARN(Neither pspell nor aspell was found -- disabling spell checking)
+- AC_MSG_WARN(---------------------------------------------------------------)
+- sleep 5
+- SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
+- SPELL_LIB=''
++ if test "$PSPELL" = "yes"
++ then
++ ALLSPELLOBJ='spellcheckerPspell.$(OBJEXT)'" $ALLSPELLOBJ"
++ AC_DEFINE_UNQUOTED(USE_PSPELL, 1, [ Use aspell library for spell checking ])
++ SPELL_OBJ='spellcheckerPspell.$(OBJEXT)'
++ SPELL_LIB='-lpspell'
++ else
++ AC_MSG_WARN(---------------------------------------------------------------)
++ AC_MSG_WARN(Neither pspell nor aspell was found -- disabling spell checking)
++ AC_MSG_WARN(---------------------------------------------------------------)
++ sleep 5
++ SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
++ SPELL_LIB=''
++ fi
+ fi
+ fi
+
diff --git a/mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch b/mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch
new file mode 100644
index 000000000000..4cd5206a145f
--- /dev/null
+++ b/mail-client/cone/files/cone-0.86-skip-rfc2045-test.patch
@@ -0,0 +1,11 @@
+--- cone-0.86/rfc2045/Makefile.am.orig
++++ cone-0.86/rfc2045/Makefile.am
+@@ -77,6 +77,6 @@
+ endif
+
+ check-am:
+- @SHELL@ $(srcdir)/testsuite | cmp -s - $(srcdir)/$(TESTSUITE)
+- @SHELL@ $(srcdir)/testsuitemm | cmp -s - $(srcdir)/testsuitemm.txt
++# @SHELL@ $(srcdir)/testsuite | cmp -s - $(srcdir)/$(TESTSUITE)
++# @SHELL@ $(srcdir)/testsuitemm | cmp -s - $(srcdir)/testsuitemm.txt
+ @SHELL@ $(srcdir)/testrfc3676parsersuite | diff -U 3 $(srcdir)/testrfc3676parsersuite.txt -
diff --git a/mail-client/cone/files/cone-0.90-gnutls3.patch b/mail-client/cone/files/cone-0.90-gnutls3.patch
new file mode 100644
index 000000000000..23f187bb0182
--- /dev/null
+++ b/mail-client/cone/files/cone-0.90-gnutls3.patch
@@ -0,0 +1,72 @@
+diff --git a/tcpd/configure.in b/tcpd/configure.in
+index 7261515..406914e 100644
+--- a/tcpd/configure.in
++++ b/tcpd/configure.in
+@@ -356,7 +356,7 @@ then
+
+ CPPFLAGS="$save_CPPFLAGS"
+ else
+- have_gnutls="no: pkgconfig --modeversion gnutls failed"
++ have_gnutls="no: pkgconfig --modversion gnutls failed"
+ fi
+ else
+ have_gnutls="no: pkg-config not found"
+@@ -368,7 +368,15 @@ if test "$have_gnutls" = "yes"
+ then
+ LIBCOURIERTLSGNUTLS="libcouriertlsgnutls.la"
+ CPPFLAGS="$CPPFLAGS `$PKGCONFIG --cflags gnutls`"
+- gnutlsdep="`$PKGCONFIG --libs gnutls` -lgnutls-extra"
++ have_gnutls3=no
++ PKG_CHECK_EXISTS([gnutls >= 3.0], [have_gnutls3=yes])
++ if test "x$have_gnutls3" = "xno"
++ then
++ gnutlsdep="`$PKGCONFIG --libs gnutls` -lgnutls-extra"
++ else
++ gnutlsdep="`$PKGCONFIG --libs gnutls`"
++ AC_DEFINE([HAVE_GNUTLS3], [1], [Use GnuTLS3])
++ fi
+ fi
+
+ AC_CHECK_SIZEOF(gnutls_transport_ptr_t,0, [
+diff --git a/tcpd/libcouriergnutls.c b/tcpd/libcouriergnutls.c
+index 4aa4996..ef8cb70 100644
+--- a/tcpd/libcouriergnutls.c
++++ b/tcpd/libcouriergnutls.c
+@@ -9,7 +9,9 @@
+ #include "tlscache.h"
+ #include "soxwrap/soxwrap.h"
+ #include <gnutls/gnutls.h>
++#ifndef HAVE_GNUTLS3
+ #include <gnutls/extra.h>
++#endif
+ #include <gnutls/x509.h>
+ #include <gnutls/openpgp.h>
+ #include <stdio.h>
+@@ -146,7 +148,11 @@ static const struct intmap {
+ { NULL, 0}
+ }, all_comps[]={
+ { "DEFLATE", GNUTLS_COMP_DEFLATE},
++#ifndef HAVE_GNUTLS3
+ { "LZO", GNUTLS_COMP_LZO},
++#else
++ { "ZLIB", GNUTLS_COMP_ZLIB},
++#endif
+ { "NULL", GNUTLS_COMP_NULL},
+ { NULL, 0}
+ }, all_certs[]={
+@@ -408,6 +414,7 @@ ssl_context tls_create(int isserver, const struct tls_info *info)
+ return (NULL);
+ }
+
++#ifndef HAVE_GNUTLS3
+ if (gnutls_global_init_extra() < 0)
+ {
+ gnutls_global_deinit();
+@@ -416,6 +423,7 @@ ssl_context tls_create(int isserver, const struct tls_info *info)
+ errno=EINVAL;
+ return (NULL);
+ }
++#endif
+ }
+
+ if (!(words=splitwords(safe_getenv(p, "TLS_PROTOCOL",