summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.16.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index b8b85bf62e73..d75f2e68f35f 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.15.5.tar.xz 19332 BLAKE2B b5d552500584888d6fd2662e7332623f51ec4a90885c983f492fbff8768b144a5d0bfff8e7466f68b833bbea436b9424b55f221402e1c9ddc8626be63910b521 SHA512 4a1a0b6f4d607a71b2dee3317acd0af1c76991a628be50d67c8231d756255577fe90e0f938050c8f6d6f295d5299deb8a88afbd7eac28050d3b905267bfd7636
DIST kwallet-pam-5.16.2.tar.xz 19644 BLAKE2B 75b3242dd876d90ed356d99cdaa60cc771d6240f6d2407636a73243ed77209d5a936380dfc8e612d18f65c1ecf0d0d13ac4aeda9b08936c238f977f8a7b8d1f6 SHA512 60273319ccccd199e9ff3e3a8509a9d46b70cd24ca36c633dfeb65ebaeb04fd6ac458a6a9ec029acacb11cb3d476bd6f7e898cb999c6a12d3ec3c386a79f3eb0
+DIST kwallet-pam-5.16.3.tar.xz 19568 BLAKE2B c44235c5c8dd50e556393fa8bc31e270e31376b1864b5cd239e386690f26bea008bbecfd8ca9a83dd7f155fefd7370e013bf1d2cbcafa1e293b69ad75969f699 SHA512 f5178e412c7802cf2b39139164fb2878e2765b51edd7bd26b2de156e7facb049cc1f299c7611d06abb308f7df9c79c4992abd6494cc2c60db0db7c2ef0c0fbc2
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.16.3.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.16.3.ebuild
new file mode 100644
index 000000000000..f3e1c598ec6c
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.16.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kwallet)
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}